Volvo XC40 Forum banner
41 - 60 of 65 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #41 ·
Latest update last friday I was told there was low voltage detected. They replaced the 12v battery. Told me they were sending logs to Volvo and would get back to me Monday. Ultimately I get no call from the dealership until I email the GM asking about the status of returning the car. I'll skip the he said she said part and just say I had more issues feeling mislead by the service department and not very confident they had done anything more than throw another part at the problem.

Earlier today I went to pick up the car and everything appears to be working. Instead of just leaving with my car I had to make a big stink at the dealer and get them to appraise it for trade in. The GM I've been working with left the state and is "unreachable" and the only one who can speak with Volvo corporate. Plenty of the staff finally agreed it's not right what's happened but no one can do anything. Wait for Volvo corporate. I leave. Upset. I don't feel whole with the way this has worked out.

I would have been more understanding that there are bugs and things in my car if it wasn't being told to me by a group that I'm finding to be over all very rude, and it hadn't been happening since the car was a few days old.

Fortunately I got an email from Volvo corporate this evening and they have approved for me to receive trade in assistance. I'm not sure exactly what that's going to mean. I'm not 100% sure I want another Volvo. I'd 100% rather work with a different dealership which I requested. I guess more to come.
 

·
Registered
Joined
·
1,888 Posts
That is what I have is trade assistance to move from my 21 XC40 to C40. I can't get an answer on how that works, but I have never seen a car maker do this so often. There are a few people on the forum here that have had their cars swapped. To me it sounds liek you are buying a new car and Volvo compensates the dealer for the gap in the traded car to the new car. I still can't get an answer on whether I need to get a new loan or of the bank will just update the lien VIN. The advantage of doing a new transaction is ability to file for another tax credit. Since we got 2 XC40s in 21 I get to file for each of those and if they treat this as a new purchase then I will get on in 22 on my 23 taxes.

If you don't want another Volvo then run out the 30 day clock and get a lemon law attorney. The fact that they offered trade assistance is almost an admission the car is an issue. The manufacturer pays for lemon law attorney, and 99% will accept your case for free as long as they feel they will win. Other options is talk to Volvo and say you are done and they can buy it back or you file lemon law. The one attorney I spoke to said Volvo was rather easy to work with, vs. other makers that will fight the process.
 

·
Registered
Joined
·
226 Posts
Is it possible for you to list the components/parts that they replaced?
You did indicate the TCAM module was replaced. I am curious if they also did the antenna and what other parts were included. It would be on the work order that they gave you on return of the car.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #44 ·
Is it possible for you to list the components/parts that they replaced?
You did indicate the TCAM module was replaced. I am curious if they also did the antenna and what other parts were included. It would be on the work order that they gave you on return of the car.
The antenna recall was performed so it was replaced as well as the 12v battery.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #45 ·
Vehicle Car Automotive mirror Automotive design Fixture

Today as I get in the car this thing fell out of the headliner of the car. Exactly the reason why I don't want one that was taken apart and put back together already... Seems to have gone back in fine but for brand new car money I'm not happy the dash and headliner have already been mucked with several times. I've done enough work on cars myself to say I know these things never go back the same.
 

·
Registered
Joined
·
15 Posts
You can add my 2021 XC40 Recharge to the no LTE/GPS club. 3 Days ago the very buggy Sirius XM radio started working for the first time ever, but then at the same time, the Cellular/GPS got the dreaded “x” in the icon and stopped working. No LTE, no GPS. Waited 3 days hoping it would clear, nothing. Tried all the reset options (defrost/home button), nothing. So now it is at the dealer. I’ll let the group know if 1) if they can get it fixed, 2) what exactly was fixed/replaced, 3) if the fix is durable, meaning the no LTE/GPS problem does not return. Wish me luck!
 

·
Registered
Joined
·
2,616 Posts
You can add my 2021 XC40 Recharge to the no LTE/GPS club. 3 Days ago the very buggy Sirius XM radio started working for the first time ever, but then at the same time, the Cellular/GPS got the dreaded “x” in the icon and stopped working. No LTE, no GPS. Waited 3 days hoping it would clear, nothing. Tried all the reset options (defrost/home button), nothing. So now it is at the dealer. I’ll let the group know if 1) if they can get it fixed, 2) what exactly was fixed/replaced, 3) if the fix is durable, meaning the no LTE/GPS problem does not return. Wish me luck!
Good luck.
 
  • Like
Reactions: Phil Z.

·
Registered
2021 XC40 Recharge P8 - Thunder Gray
Joined
·
63 Posts
You can add my 2021 XC40 Recharge to the no LTE/GPS club. 3 Days ago the very buggy Sirius XM radio started working for the first time ever, but then at the same time, the Cellular/GPS got the dreaded “x” in the icon and stopped working. No LTE, no GPS. Waited 3 days hoping it would clear, nothing. Tried all the reset options (defrost/home button), nothing. So now it is at the dealer. I’ll let the group know if 1) if they can get it fixed, 2) what exactly was fixed/replaced, 3) if the fix is durable, meaning the no LTE/GPS problem does not return. Wish me luck!
Yes, please let us know. We have exactly the same problem. I am a new member of the no LTE/GPS club. My appointment is until Feb. 11 at the dealer. Good luck. See attached:

Update: 01/13/2021 - This morning it suddenly came back! It worked after 4 days without connection. I will cancel my appointment with the dealer within this week. Hopefully it will stay connected.
 

·
Registered
Joined
·
15 Posts
Yes, please let us know. We have exactly the same problem. I am a new member of the no LTE/GPS club. My appointment is until Feb. 11 at the dealer. Good luck. See attached:
Will do. Strange all these seem to be failing more rapidly now. Hopefully Volvo can figure it out and get it fixed for good.
 

·
Registered
Joined
·
2,616 Posts
Will do. Strange all these seem to be failing more rapidly now. Hopefully Volvo can figure it out and get it fixed for good.
If it is a water issue then time + weather will degrade the ability to keep the system dry.

Temperature might effect components.

The new software might handle errors less eloquently.

Now I go and take my ritualistic have commented on a lte/tcam thread shower to make sure the Stink does not infect Margo!!
 
  • Like
Reactions: improvius

·
Registered
2021 XC40 Recharge
Joined
·
241 Posts
Yes, please let us know. We have exactly the same problem. I am a new member of the no LTE/GPS club. My appointment is until Feb. 11 at the dealer. Good luck. See attached:
Watched your video and even though your LTE is x out you never reset modem, there is a newer way to reset modem now where you turn on windshield defrost then right away press and hold defrost switch for 30-45 secs, you should notice SOS flash red and after 1-2 mins everything resets.
Good Luck!
 

·
Registered
2021 XC40 Recharge P8 - Thunder Gray
Joined
·
63 Posts
Watched your video and even though your LTE is x out you never reset modem, there is a newer way to reset modem now where you turn on windshield defrost then right away press and hold defrost switch for 30-45 secs, you should notice SOS flash red and after 1-2 mins everything resets.
Good Luck!
Thank you 340driver, I already tried that too, but no luck either. :(
Update: 01/13/2021 - This morning it suddenly came back! It worked after 4 days without connection. I will cancel my appointment with the dealer next week.
 

·
Registered
‘22 XC40 Recharge Twin in Denim Blue MFD 6/21
Joined
·
333 Posts
It’s been a week since mine came out of the dealer and other than the upgrade to 1.8.1 and the shark fin antena recall, no hardware was changed. So far so good. Crosses fingers that fixed the problem.
 

·
Registered
2022 XC40 Recharge
Joined
·
114 Posts
Is the Shark Fin an official Volvo Recall? If so, has everyone gotten a notification? I haven't.
 

·
Registered
‘22 XC40 Recharge Twin in Denim Blue MFD 6/21
Joined
·
333 Posts
Is the Shark Fin an official Volvo Recall? If so, has everyone gotten a notification? I haven't.
I doubt is official. But if your issue relates to what the recall is for then they’ll do it.
From what you see on the recall it is basically just tape.

Edit: is actually a service bulletin, not an official recall. My bad.
 

Attachments

·
Registered
Joined
·
117 Posts
To add another experience, I was having frequents LTE/GPS outages on 1.81 software. It seemed that the outages occurred a bit more frequently around driver profile switches (my wife drove and parked, I would unlock with my key and drive, LTE/GPS goes out). About a week ago, I unpaired both keys, turned the car all the way off for a couple of minutes, paired key 1 to profile 1, turned car off and waited, paired key 2 to profile 2). Since then, no LTE/GPS outages. Might be a total coincidence. Will keep reporting back…
 

·
Registered
‘22 XC40 Recharge Twin in Denim Blue MFD 6/21
Joined
·
333 Posts
To add another experience, I was having frequents LTE/GPS outages on 1.81 software. It seemed that the outages occurred a bit more frequently around driver profile switches (my wife drove and parked, I would unlock with my key and drive, LTE/GPS goes out). About a week ago, I unpaired both keys, turned the car all the way off for a couple of minutes, paired key 1 to profile 1, turned car off and waited, paired key 2 to profile 2). Since then, no LTE/GPS outages. Might be a total coincidence. Will keep reporting back…
Interesting. We only use/share one profile and use/share the black key.
 

·
Registered
Joined
·
47 Posts
I have had the LTE problem intermittently and I just do the defrost reset and it works every time. I don't want to do this forever but it doesn't bother me at all at this point. My LTE indicator actually said "3g" for a while the other day when it wasn't working. That's a new one for me. Usually just a little "x".
 

·
Registered
Joined
·
47 Posts
For me the defrost reset never worked.
Have you tried the variations? I tap the left defrost button once and then immediately hold it down for about 30 seconds and release. The full blast defrost blowing while I'm holding down the button. Around the time the LTE/GPS starts working. I park in an underground garage so I lose connection every evening and when I leave in the morning the LTE reconnects about half the time I guess.
 
41 - 60 of 65 Posts
Top