Volvo XC40 Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
Played around with this for a few hours today, biggest take away are below to get it working on the March 1 2021 Android Patch Level.

Steps are in order for what worked after a few weeks of trying and failing, Android OS phone FYI.

  • Setup a new account on the website: https://volvoid.eu.volvocars.com/Account/initaccount?language=en&market=US
  • If in the US Market had to enter +1 before area code and number to get that to work
  • Download and install the Volvo On Call (VOC) app from the Play Store
  • Login with credentials above
  • Bring all keys (2 or 3) the dealer provided when getting into your car
  • Ensure you have cell service (not tested on wifi) when in the car
  • Disable the Bluetooth link on your phone to the XC40, this was important as many things from the VOC app do not work while sitting in the car testing
  • In the XC40 Settings > Accounts > Volvo On Call and Add New
  • On the VOC App follow the prompts to add your car, we saw a warning the XC40 Recharge wasn't supported yet, yet it works
  • Connected the phone VOC app to the car via the VIN and keycode
  • Left the car and forget to grab the keys, shockingly you can lock the car from the VOC app with all sets of keys IN THE CAR, thankfully the app let me open the car back up!
  • Tested the climate controls, at the moment you can only turn it on and off, it then states "will be ready in approx. 30 minutes", no idea what that means
  • Tested the door locks, work perfectly
  • Tested what happens when charging, it's unfortunately not much, no way to set when to charge to get discounted over night rates, etc.

YMMV and no guarentees on anything above, but it did finally work for me with the bluetooth off and removing / adding back the phone app, having driving!
 

·
Registered
Joined
·
1,678 Posts
Nice instructions. Glad they worked for you. Alas they are probably not going to get this beta/alpha software up on most P8.
Still they will probably still be relevant when they get it actually working :)

Enjoy your voc. I look forward to it for mine one day.
 

·
Registered
Joined
·
7 Posts
I believe I successfully paired the app with my car. However it doesn’t populate the data. I heard that this could take a couple of days but this is now the 4th day.

967
 

·
Registered
Joined
·
1,678 Posts
That is not called successfully pairing and is where mine ended up and has been stuck at for a long time.
It is in fact a non functioning voc. Be nice when they roll out the working version but that is not today :)

The population time myth is just another bug. For some folks it works immediately. Others it takes a while. Others it never works. Just bugs. System is working as it is meant to at this point which is it working for a lot of people. :)

Something to ask Santa for for Xmas.
 
  • Like
Reactions: Markus E

·
Registered
Joined
·
47 Posts
Let us know if your dealer could fix it.
Finally fixed! The dealer worked with Volvo and they did Tech Journal 35943: Needed to rest the TCAM and IHU, with a certificate reload.

They had me wait 48 hours to try the pairing and also told me to make sure the phone was not connected to the car. So when they did the reset above, it took all of that connection out and I just removed the connection on my phone as well via the Bluetooth settings in iOS. This morning went into the car with all the keys and successfully paired with the Volvo Cars app and see all the glorious app options and my car now. What a miracle!
 

·
Registered
Joined
·
1,678 Posts
Wow. It took that much effort to get it working … I hope they can
A) streamline the process
B) share the how with other dealerships

Congratulations.
 

·
Registered
Joined
·
76 Posts
Finally fixed! The dealer worked with Volvo and they did Tech Journal 35943: Needed to rest the TCAM and IHU, with a certificate reload.

They had me wait 48 hours to try the pairing and also told me to make sure the phone was not connected to the car. So when they did the reset above, it took all of that connection out and I just removed the connection on my phone as well via the Bluetooth settings in iOS. This morning went into the car with all the keys and successfully paired with the Volvo Cars app and see all the glorious app options and my car now. What a miracle!
Was your issue The Error Code 0 one, after pairing successfully to the phone but not being able to do anything in the app?
 

·
Registered
Joined
·
14 Posts
Finally fixed! The dealer worked with Volvo and they did Tech Journal 35943: Needed to rest the TCAM and IHU, with a certificate reload.

They had me wait 48 hours to try the pairing and also told me to make sure the phone was not connected to the car. So when they did the reset above, it took all of that connection out and I just removed the connection on my phone as well via the Bluetooth settings in iOS. This morning went into the car with all the keys and successfully paired with the Volvo Cars app and see all the glorious app options and my car now. What a miracle!
Volvo tech also fixed mine..after Volvo denied there was an issue..I had to send an email to dealership owner before they decided to get the guy to come from Orlando
 
1 - 13 of 13 Posts
Top