Volvo XC40 Forum banner

21 - 40 of 46 Posts

·
Registered
Joined
·
142 Posts
So you replaced the software labeled march 18 with April 26th? In the about screen?
No, the thing labeled March 18 is just the Android "Kernel" (the core OS).

I'm guessing the the long-name thing below that (QA1A210116.001.ARTINFO.QAB.5-13-g7441a9224) is the latest build of the Infotainment software. Which I believe is the latest version from April 26 - even though it seems impossible to really tell anything from how it's labeled.
 

·
Registered
Joined
·
188 Posts
No, the thing labeled March 18 is just the Android "Kernel" (the core OS).

I'm guessing the the long-name thing below that (QA1A210116.001.ARTINFO.QAB.5-13-g7441a9224) is the latest build of the Infotainment software. Which I believe is the latest version from April 26 - even though it seems impossible to really tell anything from how it's labeled.
Yes - thanks for clarifying what I was trying to say.
 

·
Registered
Joined
·
516 Posts
What is your build number with the April 27th update welland?

The long number that is QA1A210116.001.ARTINFO.QAB.5-13-g7441a9224
For me.

Cheers
 

·
Registered
Joined
·
278 Posts
Just tried it - had all 3 keys in the car - installed the updated app on my phone - car said it found the keys - worked thru the app entered the 17 digit VIN - tried to pair the phone when in the app in the car - and it would not pair - on the app on the phone is stated not able to complete at this time not available for the Recharge - they are working on it.
Even signed out of the app and then back in again - but no dice. Still have to wait unless you have had a different experience - if so let us know what you did!!
EXACT same experience here as well
 

·
Registered
Joined
·
142 Posts
Is April 27th software THE latest one ?
I think mine has the March version
The version they BUILT on March 18 is the version they RELEASED on April 27th. Presumably it took a month of testing & bug-fixing before it was ready. Unfortunately, Volvo is making it too confusing for us to determine which version we have.

As as far as I know - none of us have yet received an actual OTA update. The March 18 (April 27) version had to be installed by a dealer. You'd definitely know if we got an OTA update. Assuming it works like our Polestar2 cousins, you'll see big scary warnings requiring you to confirm it will take 90 minutes to install, your car will be unusable during that time, must be charged at least 40% before updating, etc.
 

·
Registered
Joined
·
96 Posts
I believe if you have not rec'd the 26 April software update then you will not be able to enable VOC now that it has been released - in the about screen the date should show March vs. what it was when we picked up our cars showing January. Could be wrong but that is my thought.
I have the update from April (we picked up the vehicle shortly after it was released), so I was hopeful it would work. I had other things to do so I somewhat gave up on trying to get past the error before making the post, but I’m going to see if I can give it another shot tonight. Figure the car got to take a nap, so maybe that’ll help :)
 

·
Registered
Joined
·
57 Posts
I took an additional step today that - I think - made the VoC app update more quickly and made climate control work.

Signed into my Volvo account on the car itself, in addition to singing on via the iPhone app.

On the car screen, I went to Settings (gear icon in lower right) -> Accounts -> add account -> Volvo and then entered my Volvo account username and password. (already had accounts created for Google and NPR on this page).

I got this idea from some of the Volvo docs that were up this morning at this link: https://www.volvocars.com/en-ca/support/topics/latest-information/xc40-recharge-pure-electric

But for some reason those pages are blank right now (they had content this morning).
 

·
Registered
Joined
·
278 Posts
I took an additional step today that - I think - made the VoC app update more quickly and made climate control work.

Signed into my Volvo account on the car itself, in addition to singing on via the iPhone app.

On the car screen, I went to Settings (gear icon in lower right) -> Accounts -> add account -> Volvo and then entered my Volvo account username and password. (already had accounts created for Google and NPR on this page).

I got this idea from some of the Volvo docs that were up this morning at this link: https://www.volvocars.com/en-ca/support/topics/latest-information/xc40-recharge-pure-electric

But for some reason those pages are blank right now (they had content this morning).
  • I've tried all above, still can't even sync to VIN to begin with
  • Ditto - all blanked out now on the contents to the link.....HHmmmmm
 

·
Registered
Joined
·
278 Posts
Works like a dream! Ok, so my neighbours are thinking “why is he sat in his car on the drive again…?” But the charge status, climate pre heat and locking all work great!
It’s great to get confirmation from others that it IS indeed working (or doe some, to some Degree). This itself forces sales/dealer to do their diligence vs saying “not ready till 2022”. Now we can say “it’s already working for many....can you find out ?”
 

·
Registered
Joined
·
516 Posts
Question sub for how many is it working and what did they have to do to get it there.

I suppose a factory reset is in order … just everything else is working at the moment …
 

·
Registered
2021 White XC40 Recharge P8
Joined
·
85 Posts
Question sub for how many is it working and what did they have to do to get it there.

I suppose a factory reset is in order … just everything else is working at the moment …
Working for 9 straight days - iOS ver 5.0.1
1. Paired phone app at dealer - not working
2. Deleted app on phone and reinstalled - not working- would not allow allow phone to be deleted as connected device
3. Factory reset to unpair phone app, re-paired w/ 3 keys in car, enabled VOC permission and Volvo ID signed on in settings - working but no data (iOS ver. 4.9)
4. next day working - data on SoC, lock/unlock working, climate control start/stop
5. occasional avatar but no data - restart of WiFi in car or moving phone closer to enable Bluetooth connection restored to working
6. installed ver. 5.0.1 - app loads data faster
 

·
Registered
Joined
·
142 Posts
I took delivery of my P8 on April 30. Setup & paired the VOC myself a couple days later - using 3 keys - no dealer intervention required.

But still works only intermittently. Sometimes nothing, sometimes just lock/unlock, occasionally will show SOC and allow climate start. But I think the "intermittent" is more due to problems on their back-end servers, not on my end. As pointed out here by a Volvo person, they are (were?) targeting the week of June 13 for some kind of broader rollout where things should work more consistently.

EDIT: I've updated my iPhone app several times, now on ver 5.01. Same intermittent behavioe regardless of phone app version.
 
21 - 40 of 46 Posts
Top