Volvo XC40 Forum banner
41 - 60 of 91 Posts

·
Registered
XC40 Recharge Twin
Joined
·
193 Posts
A quick update since they replaced my TCAM and sealed the antenna.\

This may be coincidence, luck, timing, or it may be related to the new TCAM

The VOC app has worked without any hitches. It connects with the phone and gives updates without issues.

The GPS, LTE and internet wifi connections have been instantaneous. When I log in for a podcast or
Sirius, the connection occurs immediately and no issues with station changes.

I will update this if the LTE/GPS and app continue to work as advertised.

But, for the moment, the new TCAM seems to have fixed all of the gremlins....
That's great to hear. Mine mostly works but is intermittent every once in a while. Unfortunately it's not intermittent enough to take it into the dealership.
 

·
Registered
Joined
·
326 Posts
Discussion Starter · #42 ·
Does your Voc give temp?
My voc works 90% recently but have never seen temp. Including straight after public charging.

Is temp only seen when and soon after home charging?
I'm not certain by "temp". If you mean climate, then it works for climate whether plugged in or not. I can turn on climate start at all times.

If there is a "temp" reading, please let me know where it might be....I don't have one on android.
 

·
Registered
Joined
·
3,778 Posts
I'm not certain by "temp". If you mean climate, then it works for climate whether plugged in or not. I can turn on climate start at all times.

If there is a "temp" reading, please let me know where it might be....I don't have one on android.
Sounds like you like me do not get the temp reading. Let me see if I can find someone’s picture of it on here. .

 
  • Like
Reactions: BuzzyBud

·
Registered
Joined
·
181 Posts

·
Registered
Joined
·
326 Posts
Discussion Starter · #45 ·
I did a quick search for this issue. From what I can surmise:
1.) It represents a feed of the local weather
or
2.) It isn't available for the VOC on the Recharge... but is noted as showing the car temperature on the non-recharge VOC.

I'm not certain why it would show up on the Recharge VOC as I can't find anything that lists it as an option.

Climate control continues to work instantly as does the charge level information and charge status.

I never noticed but when the climate is heating the car, it show heat coming out of the vents.

Helmet Automotive lighting Font Automotive design Screenshot
 

·
Registered
Joined
·
42 Posts
For the owners with chronic LTE connection issues and other gremlins -- Have you checked your car and can you actually see a gap between the antenna cover and roof as shown in the service bulletin? I am curious to see photos of gap vs. non-gap vehicles.
 

·
Registered
Joined
·
42 Posts
I looked at all the pdfs and didn't see a picture showing the gap? can someone point me in the right direction? thanks.
I was referring to this picture. It doesn't use the word "gap" but says that the cover should be in contact with roof with no space. Honestly the check seems vague so I was wondering if there is a noticeable gap between cover / roof on problematic cars. Or if you can easily rock the antenna from side to side.


Font Rectangle Cap Electric blue Output device
 

·
Registered
XC40 Recharge Twin
Joined
·
193 Posts
I was referring to this picture. It doesn't use the word "gap" but says that the cover should be in contact with roof with no space. Honestly the check seems vague so I was wondering if there is a noticeable gap between cover / roof on problematic cars. Or if you can easily rock the antenna from side to side.


View attachment 2183
Based on this document I've told the family to be very careful cleaning snow off the roof in the area of the antenna. This seems to be a weak point of the car's design/build.
 

·
Registered
Joined
·
3,778 Posts
I suppose one should also be careful when washing the car and blasting the roof with a hose.

This is great information and should help getting folks tcam issues resolved.

I wonder how expansion and contraction effects it. My car has gone through 100f variance so far without leaking!!
 

·
Registered
Joined
·
3,778 Posts
hmm should i bust out the GE Advanced Silicone 2® Window & Door Sealant to be double sure?
I was wondering that myself. If it is a weak spot should we reinforce it … does reinforcing it invalidate the warrantee …

Somebody knows but not me :)
 

·
Registered
Joined
·
156 Posts
I’m on day 5 of no LTE (empty triangle indicator with “x” in lower corner) and no GPS (though the icon is there). Funny thing is, the Volvo was in with dealer in early December, and re-sealing the antenna area was listed in the receipt for work done. After I got it back, the LTE and GPS worked great for about five days. Then, a couple of rainy days, and then the LTE / GPS went out and has failed to work ever since. It might be the antenna leak issue, or maybe the dealer failed to reconnect some cable (battery?), or maybe the TCAM is just failing for some other reason.

Dealer doesn’t have an appointment until Jan 20th - hope to get it fixed then. Will report back…
 

·
Registered
2022 Late XC40 Twin, 2017 BRZ
Joined
·
954 Posts
I’m on day 5 of no LTE (empty triangle indicator with “x” in lower corner) and no GPS (though the icon is there). Funny thing is, the Volvo was in with dealer in early December, and re-sealing the antenna area was listed in the receipt for work done. After I got it back, the LTE and GPS worked great for about five days. Then, a couple of rainy days, and then the LTE / GPS went out and has failed to work ever since. It might be the antenna leak issue, or maybe the dealer failed to reconnect some cable (battery?), or maybe the TCAM is just failing for some other reason.

Dealer doesn’t have an appointment until Jan 20th - hope to get it fixed then. Will report back…
Maybe they re-sealed it without replacing the possibly-damaged TCAM.
 

·
Registered
Joined
·
326 Posts
Discussion Starter · #58 ·
i hope @Homer keeps us updated on the progress post fix.
Since they replaced the TCAM module, GPS/LTE and connectivity has been perfect and instant on car start.

VOC has worked without a hitch.

It may be the new TCAM or coincidence, but I have not other explanation other than the new module.

I will keep an update if there are any new issues.

As an aside, I do note that in the service bulletin, Volvo does not recommend replacing the TCAM. Only resealing the antenna.

In my case, the service manager said there was clear evidence of moisture. With three power failures, they replaced the TCAM.

Brown Rectangle Beige Font Pattern
 

·
Registered
Joined
·
326 Posts
Discussion Starter · #59 ·
Since they replaced the TCAM module, GPS/LTE and connectivity has been perfect and instant on car start.

VOC has worked without a hitch.

It may be the new TCAM or coincidence, but I have not other explanation other than the new module.

I will keep an update if there are any new issues.

As an aside, I do note that in the service bulletin, Volvo does not recommend replacing the TCAM. Only resealing the antenna.

In my case, the service manager said there was clear evidence of moisture. With three power failures, they replaced the TCAM.

View attachment 2189
Rectangle Font Material property Parallel Screenshot
 

·
Registered
Joined
·
500 Posts
Since they replaced the TCAM module, GPS/LTE and connectivity has been perfect and instant on car start.

VOC has worked without a hitch.

It may be the new TCAM or coincidence, but I have not other explanation other than the new module.

I will keep an update if there are any new issues.

As an aside, I do note that in the service bulletin, Volvo does not recommend replacing the TCAM. Only resealing the antenna.

In my case, the service manager said there was clear evidence of moisture. With three power failures, they replaced the TCAM.

View attachment 2189
Curious. Are you also running software version 1.8.1?
 
41 - 60 of 91 Posts
Top