Volvo XC40 Forum banner
41 - 60 of 143 Posts

· Registered
Joined
·
407 Posts
Am I weird to have 2.3.1?
I wouldn't say "weird", but maybe in a small minority of owners . . .

If I remember right, 2.3 was released, and caused some issues for some owners, so Volvo dealers were given an update for anyone using 2.3 to be updated to 2.3.1. Sometime "shortly" after the 2.3.1 release, Volvo released 2.4, but 2.4 was only available from dealers. So you fall into the category of owners that were updated to 2.3.1 by the dealer for that short timeframe between 2.3.1 and 2.4's release.

IMO, if your car is running without issue, wouldn't be concerned and you can wait until 2.5 OTA is available, maybe wait to update for a couple of weeks to make sure 2.5 doesn't introduce new issues.
 

· Registered
Joined
·
26 Posts
I wouldn't say "weird", but maybe in a small minority of owners . . .

If I remember right, 2.3 was released, and caused some issues for some owners, so Volvo dealers were given an update for anyone using 2.3 to be updated to 2.3.1. Sometime "shortly" after the 2.3.1 release, Volvo released 2.4, but 2.4 was only available from dealers. So you fall into the category of owners that were updated to 2.3.1 by the dealer for that short timeframe between 2.3.1 and 2.4's release.

IMO, if your car is running without issue, wouldn't be concerned and you can wait until 2.5 OTA is available, maybe wait to update for a couple of weeks to make sure 2.5 doesn't introduce new issues.
Interestingly, my V90CC B5 is rocking 2.3 without issue, albeit the app has never been useful beyond locking doors
 

· Registered
'22 XC40 Pure Elec. Ultimate
Joined
·
247 Posts
I had this Spotify glitch come up yesterday. It showed both the sliding bar control and the skip ahead/back controls. It was instantly resolved by tapping the 3 dots on the right hand side. I had never seen this on earlier versions of the software.

Communication Device Font Gadget Portable communications device Gas
 

· Registered
'22 XC40 Pure Elec. Ultimate
Joined
·
247 Posts
Just another v2.5 observation - the cruise control is now more "controlled" than previously. And by that I mean... before if I set the speed limit, I had a variation of say +/- 6kph.

I noticed today that is a much narrower window when cruising - it's now back to +/- 2kph.

And also the trip meter controls are different - though I think this was introduced in v2.3 or v2.4. I'm only seeing it now because I went from v2.2 -> v2.5.
 

· Registered
2022 XC40 Recharge Twin Fusion Red
Joined
·
1,507 Posts
Just another v2.5 observation - the cruise control is now more "controlled" than previously. And by that I mean... before if I set the speed limit, I had a variation of say +/- 6kph.

I noticed today that is a much narrower window when cruising - it's now back to +/- 2kph.

And also the trip meter controls are different - though I think this was introduced in v2.3 or v2.4. I'm only seeing it now because I went from v2.2 -> v2.5.
That's great news...I much prefer the smaller window on the cruise that was what we had when we originally got the car. I think the wider window came at around V2.2.
 

· Registered
'22 XC40 Pure Elec. Ultimate
Joined
·
247 Posts
I've now noticed several Spotify "bugs" with the v2.5 upgrade. Beyond the one pictured above, the "Play" button seems to stop working as in... you can press play to start the music/podcast, but you can't press it again to pause. The button doesn't reflect the correct status of what's going on and shows as though you're not playing anything, when infact you are. Basically it doesn't show the "||" option to suggest "press this to pause". The physical button also stops working.

The fix is to force stop/restart the app - BUT, you can't do this if you're driving because the "Apps" part of the menu (under settings) is greyed out. If you stop moving you can do it, but if you're driving the only way to get it working is to do an IHU reboot.

Also just to clarify, these may be "Spotify bugs" and not necessarily v2.5 bugs introduced by Volvo. These issues may be resolved once Spotify update their app in the AAOS store.
 

· Registered
2022 XC40 Recharge Twin Fusion Red
Joined
·
1,507 Posts
I've now noticed several Spotify "bugs" with the v2.5 upgrade. Beyond the one pictured above, the "Play" button seems to stop working as in... you can press play to start the music/podcast, but you can't press it again to pause. The button doesn't reflect the correct status of what's going on and shows as though you're not playing anything, when infact you are. Basically it doesn't show the "||" option to suggest "press this to pause". The physical button also stops working.

The fix is to force stop/restart the app - BUT, you can't do this if you're driving because the "Apps" part of the menu (under settings) is greyed out. If you stop moving you can do it, but if you're driving the only way to get it working is to do an IHU reboot.

Also just to clarify, these may be "Spotify bugs" and not necessarily v2.5 bugs introduced by Volvo. These issues may be resolved once Spotify update their app in the AAOS store.
I hope the net number of bugs decreases! ;)
 

· Registered
2022 XC40 Recharge Pure Electric
Joined
·
17 Posts
I've now noticed several Spotify "bugs" with the v2.5 upgrade. Beyond the one pictured above, the "Play" button seems to stop working as in... you can press play to start the music/podcast, but you can't press it again to pause. The button doesn't reflect the correct status of what's going on and shows as though you're not playing anything, when infact you are. Basically it doesn't show the "||" option to suggest "press this to pause". The physical button also stops working.

The fix is to force stop/restart the app - BUT, you can't do this if you're driving because the "Apps" part of the menu (under settings) is greyed out. If you stop moving you can do it, but if you're driving the only way to get it working is to do an IHU reboot.

Also just to clarify, these may be "Spotify bugs" and not necessarily v2.5 bugs introduced by Volvo. These issues may be resolved once Spotify update their app in the AAOS store.
I have this issue with V2.2, so it may be indeed on Spotify side...
 

· Registered
Joined
·
68 Posts
Beyond the one pictured above, the "Play" button seems to stop working as in... you can press play to start the music/podcast, but you can't press it again to pause. The button doesn't reflect the correct status of what's going on and shows as though you're not playing anything, when infact you are. Basically it doesn't show the "||" option to suggest "press this to pause". The physical button also stops working.
Interestingly I've seen similar-ish behavior on YouTube Music and I'm on 2.4. The play/pause button in the app UI was out of sync. The bar showing progress through the song was also blank. However, using the play pause button in the app a few times seemed to sync it back up.

Additionally, the physical play button also stopped working in that scenario, but I find that happens frequently for me. Many times when I issue a voice command with music playing, the music does not resume after the command is done processing. In those cases, the physical button stops responding too until I resume it from the music app (or with a "resume music" voice command). Then the button works again.
 

· Registered
'22 XC40 Pure Elec. Ultimate
Joined
·
247 Posts

· Registered
Joined
·
8 Posts
I went to the local dealer today, having booked an appointment a few weeks ago for the purpose of upgrading from 2.3 to 2.4.
I was told it would take 1.5 hours. After 1.5 hours my car was still where I left it. Upon inquiring, they had clearly forgotten about it and claimed they were "backed up". There was only another person with their car in service at the time.
Anyway, after half an hour they gave me back the keys and said they've upgraded to the latest version. I went to the car and checked, only to find I was still on 2.3. So I went back in and they said that that's the latest version they have, and that this new version is so good because the back up camera no longer starts in 360. I told them that I've had this "new" feature for a while, because it came with 2.3 but they continued to insist that there's no newer version than that.

Has anyone had a similar experience? How am I supposed to keep the OS up to date when 2.4 is a bottleneck that can only be performed at the dealership, but the dealership is clueless?
 

· Registered
2022 XC40 Recharge Twin Fusion Red
Joined
·
1,507 Posts
I went to the local dealer today, having booked an appointment a few weeks ago for the purpose of upgrading from 2.3 to 2.4.
I was told it would take 1.5 hours. After 1.5 hours my car was still where I left it. Upon inquiring, they had clearly forgotten about it and claimed they were "backed up". There was only another person with their car in service at the time.
Anyway, after half an hour they gave me back the keys and said they've upgraded to the latest version. I went to the car and checked, only to find I was still on 2.3. So I went back in and they said that that's the latest version they have, and that this new version is so good because the back up camera no longer starts in 360. I told them that I've had this "new" feature for a while, because it came with 2.3 but they continued to insist that there's no newer version than that.

Has anyone had a similar experience? How am I supposed to keep the OS up to date when 2.4 is a bottleneck that can only be performed at the dealership, but the dealership is clueless?
You should probably just wait for 2.5 to roll out over-the-air...give it a week or two.
 

· Registered
2021 XC40 Recharge
Joined
·
540 Posts
I went to the local dealer today, having booked an appointment a few weeks ago for the purpose of upgrading from 2.3 to 2.4.
I was told it would take 1.5 hours. After 1.5 hours my car was still where I left it. Upon inquiring, they had clearly forgotten about it and claimed they were "backed up". There was only another person with their car in service at the time.
Anyway, after half an hour they gave me back the keys and said they've upgraded to the latest version. I went to the car and checked, only to find I was still on 2.3. So I went back in and they said that that's the latest version they have, and that this new version is so good because the back up camera no longer starts in 360. I told them that I've had this "new" feature for a while, because it came with 2.3 but they continued to insist that there's no newer version than that.

Has anyone had a similar experience? How am I supposed to keep the OS up to date when 2.4 is a bottleneck that can only be performed at the dealership, but the dealership is clueless?
I would have called Volvo Canada customer servicetel:1-800-663-8255 considering update 2.4 is dealer installed only and 2.5 is out and has been announced by Volvo..
 
41 - 60 of 143 Posts
Top