Volvo XC40 Forum banner
41 - 58 of 58 Posts

·
Registered
Joined
·
3 Posts
On a C40 with 2.3 update, somehow the Google Maps app is misbehaving for me. When I punch-in a destination, before this update, Maps would tell me expected battery fullness upon reaching. After this update, Maps doesn't display projected battery information, but only arrival time!
I had the same problem before the upgrade. Rebooting the IHU fixed it for me.
 

·
Registered
2022 XC40 Ultimate, Sage Green
Joined
·
231 Posts
Is it me or when reversing the 360 camera is not triggering as often with 2.3 (when compared with earlier release where it almost always triggered 360 if anything was around while reversing)?

Got the update email on Wednesday. Got notification in the car about the upgrade Thursday. Applied and finished within 20 or so minutes, BTW.
360 seems to be activated by default forwards, and rear camera in reverse. I prefer the 360 as default and haven’t so far found an option to reset it. Need to call the dealer to ask about the persistent 15kph speed limit that kicks in after I leave a 15kph speed zone. No doubt a software bug that needs addressing.
 

·
Registered
2022 C40 Pure Electric Recharge
Joined
·
28 Posts
I haven't seen the car ask for the 2.3 updates yet and I'm on 2.2 I wonder if i can force the update.
Do not install V2.3 software update. I did and it messed up my vehicle bad. V2.3 has caused a lot of problems. I had V2.2 no problems. Just wait it out. I found that V2.3 disappeared according to other owners. If you need an update go to dealership.
 

·
Registered
Joined
·
41 Posts
Do not install V2.3 software update. I did and it messed up my vehicle bad. V2.3 has caused a lot of problems. I had V2.2 no problems. Just wait it out. I found that V2.3 disappeared according to other owners. If you need an update go to dealership.
Whatever you do, please don't tell us how it messed up your vehicle. ;)
 

·
Registered
XC40 P8 2021 - Sage Green
Joined
·
151 Posts
Looks like the line about fixing unlocking issues has vanished from Release NOtes (at least for the Swiss page).
Rectangle Font Magenta Circle Number
 

·
Registered
Joined
·
5 Posts
Installed 2.3 prior to a long trip (1800 miles) and found a few strange issues. The time on the center screen (upper right) did not change automatically when changing time zones, even after resetting and making sure the settings were correct to do so. Also have some issues with locking and unlocking the vehicle. It seems less sensitive and had it lock the mirrors in the folded position. I had to lock and unlock using various combinations of the key fob and interior lock controls to get them to unfold. Even the two button trick did not work initially. Otherwise the charging and range seemed great. The google maps estimate was almost always underestimating the amount of charge that would be available at the destination. I often added 10% during the travel between charges.
 

·
Registered
2022 XC40 Recharge Plus Sage Green
Joined
·
18 Posts
I've had 2.3 a few weeks. Hit a small bug and annoyance this morning of no Google map suddenly in driver display (did see speed limits), was working when I parked car last night. The display appears stuck in calm mode and toggle button right of steering wheel does nothing. IHU reboot did not work either. I had no phone connected via USB-C (I didn't stop Bluetooth though for iPhone connection). Google Maps works fine in center screen, however.

I have read other posts with this issue that said waiting a while with car parked and locked may do the trick. Also saw something about switching profiles - which I looked at briefly, but I only have 1 programed and was away from other fob so I couldn't test this easily.

Just wondered if others know of any other solutions.
 

·
Registered
Joined
·
3 Posts
I've had 2.3 a few weeks. Hit a small bug and annoyance this morning of no Google map suddenly in driver display (did see speed limits), was working when I parked car last night. The display appears stuck in calm mode and toggle button right of steer wheel does nothing. IHU reboot did not work either. I had no phone connected via USB-C (I didn't stop Bluetooth though for iPhone connection). Google Maps works fine in center screen, however.

I have read other posts with this issue that said waiting a while with car parked and locked may do the trick. Also saw something about switching profiles - which I looked at briefly, but I only have 1 programed and was away from other fob so I couldn't test this easily.

Just wondered if others know of any other solutions.
Had a similar issue with 2.2 when I was on a trip. Reboots of IHU did not help. Oddly it started working for me when I set my destination in Google maps with directions and then arrived at that destination. I can't recall if it started working immediately after that or if it was when I used it the next day, but I was surprised when it started working suddenly.
 

·
Registered
2022 XC40 Recharge Plus Sage Green
Joined
·
18 Posts
Had a similar issue with 2.2 when I was on a trip. Reboots of IHU did not help. Oddly it started working for me when I set my destination in Google maps with directions and then arrived at that destination. I can't recall if it started working immediately after that or if it was when I used it the next day, but I was surprised when it started working suddenly.
Waiting a few hours worked, map is back! I'll try the destination next time if this happens again, thanks. Haven't had the AC non responsive issue happen for quite a while at least (knocks on wood), but IHU reboot always fixed that immediately.
 

·
Registered
Joined
·
58 Posts
I'm just noticing that they reduced regeneration amount even more with 2.3? Is that correct? Seems crazy to keep lessening the bite with OPD. It really starts feathering off when it used to bite harder. It was perfect the way it was on the older versions. I assume feedback was that it was too aggressive and hard to modulate.
 

·
Registered
Joined
·
3,965 Posts
I'm just noticing that they reduced regeneration amount even more with 2.3? Is that correct? Seems crazy to keep lessening the bite with OPD. It really starts feathering off when it used to bite harder. It was perfect the way it was on the older versions. I assume feedback was that it was too aggressive and hard to modulate.
Different people like different things. It seems to change every time.

My suggestion is to get used to the fact it will change every time :( you can feed back but for every person who likes it one way there is another who likes it the opposite. And then there is the engineer doing the coding and their opinion (or the change orders they are working from) that define the new end result.

It is irritating that it keeps changing but it is the way it is alas.
 
  • Like
Reactions: DcinBC

·
Registered
Joined
·
705 Posts
Different people like different things. It seems to change every time.

My suggestion is to get used to the fact it will change every time :( you can feed back but for every person who likes it one way there is another who likes it the opposite. And then there is the engineer doing the coding and their opinion (or the change orders they are working from) that define the new end result.

It is irritating that it keeps changing but it is the way it is alas.
on 2.3 for a couple of weeks now - no difference for us with OPD.
 

·
Registered
Joined
·
58 Posts
Different people like different things. It seems to change every time.

My suggestion is to get used to the fact it will change every time :( you can feed back but for every person who likes it one way there is another who likes it the opposite. And then there is the engineer doing the coding and their opinion (or the change orders they are working from) that define the new end result.

It is irritating that it keeps changing but it is the way it is alas.
Well said. My issue is i'm pretty sensitive to changes on my cars, so not ideal how much they change and how often. But you're right, I will embrace the evolving nature of an over-the-air update and accept that things will at times evolve from a performance I liked.

When I got the car the throttle mapping and implementation of one pedal drive was so perfect and smooth it was hard to believe. A benchmark if you ask me. They have since added a bucking when just barely pressing the accelerator while standing still or on a slight hill, a less linear throttle response with more power low, and way less bite on one pedal. I believe this is the second round of lessening the aggressiveness of regeneration on lift.
 

·
Registered
Joined
·
306 Posts
Some folks that have updated to 2.3 reported a change in OPD "feeling", others report that it feels the same as 2.2.

I've been using OPD almost exclusively since last November, but I have to admit there are some days that it feels different to me, independent of the SW version installed in the car at the time. There are times when it feels less aggressive to me, doesn't "bite" going downhill as much as is seems to do at other times. To me, OPD always performs "similarly", but it doesn't always perform "identically".

I'm more than willing to accept that this may be nothing more than my perception on a given day, but maybe there are other factors that influence OPD's performance (outside temperature, battery temperature, state of charge, etc.). The good thing is that if there really are changes in OPD performance (independent of SW version), I feel that I adapt to it pretty quickly and adjust accordingly. OTOH, this may all be in my head and OPD always operates identically to the previous day (assuming no OTA updates were installed).
 

·
Registered
Joined
·
41 Posts
Some folks have already commented on it, but the only change that I noticed in OPD after 2.3 is that cancelling Adaptive Cruise Control doesn't give you a jarring immediate braking effect. There is a bit of coasting, before the braking happens. YMMV.
 
41 - 58 of 58 Posts
Top