Volvo XC40 Forum banner
1 - 20 of 34 Posts

· Registered
2022 XC40 Recharge Twin Fusion Red
Joined
·
1,493 Posts
Discussion Starter · #1 ·
OK, I’m trying to figure out the charge limits. We typically charge to 80%, but occasionally want to charge to 90%. Note this comment/issue is related to home charging on the provided 10A/230V charge cable. Yesterday I charged to 80% and the car finished charging, and I unplugged and locked it. Today I want to increase from 80-90% as I have a long drive tomorrow. So I get in the car, open “charging” settings and change the charge limit from 80% to 90%. Then I get out of the car, close the door, go to the charger cable, switch it on, and go to charge port and open it and the light is green...odd as it seems like it’s usually white when I go to plug in the charger. Anyway, plugged in the cable and the driver’s display comes on and says “80% - complete”...and the centre screen charging display says the limit is 80%. Hmm, I had just set it to 90%. WTF? So I get back in the car and set charge limit back up to 90% (again) and voila - car starts charging and says it will be done at 11:45. This is the 3rd time we’ve had the charge limit not “take” in the settings (both previous times were after we had charged to 90% and set back to 80%, and the subsequent charge went over 80% as if it was still set at 90%. Does the charge limit have to be set while the car is plugged in? I assumed it would take the new limit setting and apply that for all future charges until it’s changed again. Has anyone else noticed this behaviour? Note we’re still on V1.6 in our MY22 as we haven’t had OTA updates yet in Australia.
 

· Registered
Joined
·
4,154 Posts
Seems like if you change the setting after it had reached its goal it does not take the data until you start the charging processes again.

So
If it is charging you can change the limit
If it is not charging (disconnected) you can set the limit
But do not change it if it has finished its charge cycle.

It makes sense from a lazy coding perspective.

Event plug in
Start charging
Charge until limit
Shutdown charging

It actually makes complete sense from a public charger as the start of all the billing and connections is when you plug in. When it’s over it’s all over.

So maybe not lazy charging.
 

· Registered
Joined
·
4,154 Posts
Ikr. I was tempted to just say it sounds like it is by design.

But sitting on its own without the chain of consciousness it might or sounded even more silly then it did :p
 
  • Haha
Reactions: Reboot

· Registered
XC40 Recharge Twin
Joined
·
202 Posts
I do the same where I normally charge to 80% (which can last me several days as I don't do much driving) but do 90% if I have any longer drives (nothing over 100km). When I've set it to 90% I find that often it doesn't make it all the way to 90 even though it has more than enough time. It will say it will finish in X hours to 90% but then at X+4 hours it's still not there. Sometimes happens like that, other times not.
 

· Registered
2022 XC40 Recharge Twin Glacier Silver
Joined
·
569 Posts
I do the same where I normally charge to 80% (which can last me several days as I don't do much driving) but do 90% if I have any longer drives (nothing over 100km). When I've set it to 90% I find that often it doesn't make it all the way to 90 even though it has more than enough time. It will say it will finish in X hours to 90% but then at X+4 hours it's still not there. Sometimes happens like that, other times not.
Mine is set normally at 80%. Last evening I set it to 90% and this morning it was at 88% indicating that charging has finished. It is the way it works. My version is that charging was finished at 90% some time early and the car went to bed. It was cold morning and warm last evening. I thing that is perfectly normal for what I am experiencing. Happened the opposite twice - as I was driving to see percentage increase. Last time went from 86% to 87% as battery warmed. It was cold that morning too.
 

· Registered
Joined
·
35 Posts
I had the same issue on the weekend. I was at our holiday house and tried to set the charge to 100% using 240V normal power plug. It got to 90% and said “complete”. It would not go beyond 90%.
When o got back home I used my fast wall charger and it would charge to 100% no problem.
Maybe there is a soft limit when charging using a normal AC power charge cable

OK, I’m trying to figure out the charge limits. We typically charge to 80%, but occasionally want to charge to 90%. Note this comment/issue is related to home charging on the provided 10A/230V charge cable. Yesterday I charged to 80% and the car finished charging, and I unplugged and locked it. Today I want to increase from 80-90% as I have a long drive tomorrow. So I get in the car, open “charging” settings and change the charge limit from 80% to 90%. Then I get out of the car, close the door, go to the charger cable, switch it on, and go to charge port and open it and the light is green...odd as it seems like it’s usually white when I go to plug in the charger. Anyway, plugged in the cable and the driver’s display comes on and says “80% - complete”...and the centre screen charging display says the limit is 80%. Hmm, I had just set it to 90%. WTF? So I get back in the car and set charge limit back up to 90% (again) and voila - car starts charging and says it will be done at 11:45. This is the 3rd time we’ve had the charge limit not “take” in the settings (both previous times were after we had charged to 90% and set back to 80%, and the subsequent charge went over 80% as if it was still set at 90%. Does the charge limit have to be set while the car is plugged in? I assumed it would take the new limit setting and apply that for all future charges until it’s changed again. Has anyone else noticed this behaviour? Note we’re still on V1.6 in our MY22 as we haven’t had OTA updates yet in Australia.
 

· Registered
2021 XC40 Recharge
Joined
·
535 Posts
I had the same issue on the weekend. I was at our holiday house and tried to set the charge to 100% using 240V normal power plug. It got to 90% and said “complete”. It would not go beyond 90%.
When o got back home I used my fast wall charger and it would charge to 100% no problem.
Maybe there is a soft limit when charging using a normal AC power charge cable
I had this same problem once when I tried to change max charge to 100 from 90 after I had already plugged in. I finally fixed it by driving the car around the block then back into my garage and set 100 before I plugged in and everything worked as it should.
 

· Registered
2022 XC40 Recharge Twin Fusion Red
Joined
·
1,493 Posts
Discussion Starter · #9 ·
They still haven’t fixed this in V2.1 sadly. Had limit set to 90% yesterday and this AM at 6:30 car was “finished” at 80% even though both screens said charge limit set to 90%. Grrr!
 

· Registered
Joined
·
4,154 Posts
Yep, same for me. Bumped it up to 80% last night, but it still charged to 70%.
Is there a reboot and set fix or does that fail as well?

Odd how it fixates on different numbers for different people.

Have you tried charging at a level 3 to see if it follows the wrong numbers there? Maybe if lucky it will “set” a new number if you charge at a lvl 3.

Good luck.
 

· Registered
2022 XC40 Recharge Twin Fusion Red
Joined
·
1,493 Posts
Discussion Starter · #13 ·
I think if you reboot the infotainment screen, the displayed charge limit will send an update to the car's charging software's limit. It did for me.
Hmm, so basically you have to set the new limit, then reboot the ICU to get it to “take” the setting? Odd…it does seem to eventually obey after a charge or two. This AM when I had the issue, the day before I had set it to 90%…but we only charged to about 70%…then took a drive and last night plugged in (still set to 90%) and in the AM it was only 80% and “DONE” (but both screens still said 90% limit). Car was still plugged in, so I just got in and moved the limit from 90% down to 80%, then back up to 90% and it immediately started charging again…odd!
 

· Registered
2021 Glacier Silver XC40 Recharge P8
Joined
·
297 Posts
Same for me last night. First charge after 2.1 OTA and IHU reboot, I dropped the charge limit from 80% tp 50%. It charged to the old limit of 80%. First time this has EVER happened. Something's certainly amiss in 2.1.
 

· Registered
Joined
·
4,154 Posts
Same for me last night. First charge after 2.1 OTA and IHU reboot, I dropped the charge limit from 80% tp 50%. It charged to the old limit of 80%. First time this has EVER happened. Something's certainly amiss in 2.1.
All you crazy folks and your variable charge amounts! I think I changed my charge amount 11 months ago. That worked so I left it at 90 since then :p
 

· Registered
Joined
·
465 Posts
Does the fact your on 1.8 mean you have to get 2.2 or else you get evicted from the ota club?
Apparently! I got email for 2.0 but no update and I’ve received no email or update for 2.1. I want the updates but not bad enough to drive to the dealership (15 minutes). Car works beautifully so I’m good. Seems I’ve been evicted from the club anyway..
 

· Registered
2021 Glacier Silver XC40 Recharge P8
Joined
·
297 Posts
All you crazy folks and your variable charge amounts! I think I changed my charge amount 11 months ago. That worked so I left it at 90 since then :p
Yeah, you're right -- we are a little crazy. Went out for a while yesterday and drew the SOC down to 25%. Now that I have 2.1, I wanted to see the new battery indicator below 20% but knew the wife wanted to use it today and she still has a little range anxiety, so thought I would partly charge to 50%, but 2.1 had different ideas & took it to 80%. Oh well, still crazy after all these years.
 
1 - 20 of 34 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top