Volvo XC40 Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I was finally able to get the vehicle in to the on-call app. However, the only thing that I am able to do is to lock and unlock the car. The climate option is unavailable and there is no information regarding the battery. I was hoping to be able to manage charging through the app, and even try to obtain an API to pass the charge state into my charger. I have tried calling the support people but they hardly say anything other than I need to wait.

Has anyone had more luck than me on this app?
 

·
Registered
2021 XC40 Recharge
Joined
·
219 Posts
Has anyone had more luck than me on this app?
Yes, it works for most everyone, except for those who expect the car to set itself up properly without follow a specific procedure. You can use the search function of this forum for the keyword "voc" to read about others who have encountered the same problem and more.

There are some resources to read as well:
Frequently Asked Questions regarding the Volvo Cars app | XC40 Recharge Pure Electric | Support and legal articles | Volvo Support

https://personalizeyourvolvo.com/PD...Pairing Guide for XC40 Recharge-july-2021.pdf
 

·
Registered
2021 Volvo XC40 Recharge
Joined
·
43 Posts
I was finally able to get the vehicle in to the on-call app. However, the only thing that I am able to do is to lock and unlock the car. The climate option is unavailable and there is no information regarding the battery. I was hoping to be able to manage charging through the app, and even try to obtain an API to pass the charge state into my charger. I have tried calling the support people but they hardly say anything other than I need to wait.

Has anyone had more luck than me on this app?
Confirm your dealer has identified you as the owner/administrator and that you have the current version of VoC. Go to settings, profile and VoC to follow prompts to sign in and pair your phone. I called the VoC support line and they were helpful, give them a try if necessary.
 

·
Registered
2021 XC40 P8 - Onyx, 01/21, v1.7
Joined
·
48 Posts
For some reason it can take hours or even days for SOC and climate to start working with the app after you’ve set it up. Give it a couple days and keep checking!
 

·
Registered
2021 XC40 Recharge
Joined
·
219 Posts
Give it a couple days and keep checking!
While true, the waiting period is what frustrated so many of us. Many people, including myself, have waited more than the recommended time with no success, all to find out something else needed to be done in order for it to work. This is because there are so many failure points that can prevent it from working. The saying "get your ducks in a row" applies here. It's wise to read the links provided and review your settings (and don't forget about privacy and permissions).

I'll go out on a limb here... I have a hunch (similar to @SeattleCat) that the car does needs to take a nap (with doors locked) for say 15 minutes and then come back. If your settings were done correctly, the sleep/wake up action should perform a thorough communication to Volvo's backend servers (need good LTE signal). Once that interaction occurs, the phone app should be killed and relaunched. The first time, it will download your car specific data. On Android, I saw some files that it downloads in the background that seem to be specific to my vehicle. (I'll bet VIN, model, color, etc.)

In my rare case, I had all of the settings correct. After a week had transpired, it still wasn't working. Then, I decided to reboot the infotainment system AND reboot the LTE cellular modem. Amazingly, VOC started working. YMMV.
 

·
Registered
Joined
·
502 Posts
I was finally able to get the vehicle in to the on-call app. However, the only thing that I am able to do is to lock and unlock the car. The climate option is unavailable and there is no information regarding the battery. I was hoping to be able to manage charging through the app, and even try to obtain an API to pass the charge state into my charger. I have tried calling the support people but they hardly say anything other than I need to wait.
You're describing exactly how mine worked for the first 3 months: it paired fine, but only lock/unlock ever worked. Then suddenly, magically in July it started working perfectly. Nothing that I did on my end - I have to think this was Volvo finally completing the necessary cloud infrastructure roll-out, scale-up, etc.

Be sure you've exactly followed ALL of the steps in the"Pairing Guide" sticky note at the top of this forum. Pay particular attention to the permissions and adding your Volvo account. Make sure your car is parked where it has a good cell signal. And maybe wait a day or so, sometimes it does seem to take a while for your car to get fully "provisioned" in their cloud system.

As for an API, good luck with that. Given the security hoops we have to jump thru just to get this app to work (physical presence of all three keys, bluetooth pairing, Volvo account password, etc) - it seems unlikely to me they'd open up any of this to 3rd parties.
 

·
Registered
XC40 P8 Recharge 2021
Joined
·
25 Posts
There is an API in early development here: APIs
I've managed to connect to my Volvo on Call account and "authorize my car" and see the vehicle details but not actually connect to the car.
It does say it doesn't work for the XC40 Recharge BEV. Also, the token only lasts for 1 hour before you need to regenerate it.
 

·
Registered
Joined
·
61 Posts
I seemed to run into a weird bug in the permissions page where if I flipped more than one of the I think three privacy options at a time, it would mark them as enabled but as soon as I exited that settings page and came back, only the very first option I enabled would still be enabled. I think that's what messed up my first pairing experience since I did t catch it until after I had paired my phone. I ended up factory resetting the car, deleting the app from my phone, and starting over.

Once I did that, I followed the pairing instructions on the thread sticky and after enabling each privacy setting, completely exiting the settings page and then going back in to enable the next one, repeating until all three showed enabled. That process seemed to work for me and after the waiting game as described above (for me at least it was overnight), locks, climate, and charge all work. I'm pretty sure my car is on the June firmware revision.

Hope this helps someone else. I love my car but voc pairing process just seems really stupid and poorly thought out. Too many steps and places where if you deviate even slightly in the process, hoses it up completely.
 
1 - 8 of 8 Posts
Top