Volvo XC40 Forum banner
1 - 9 of 9 Posts

·
Registered
XC40 P8 Recharge 2021
Joined
·
8 Posts
Discussion Starter · #1 ·
I've just updated to the latest s/w version and noticed that the greyed out icon for cruise control/speed limiter enabled but inactive has disappeared.
As far as I can tell there's no indication as to what mode is currently active, you have turn it on to find out what's active or go into the centre screen menu to find out.
This seems like a step backwards, it was bad enough having to go into the menu to toggle modes now I can't even tell what mode is active!
I like cruise control on motorways, speed limiter at other times. there ought to be a way of toggling mode via the steering wheel.
Anyone else noticed this? Or got any ideas.

I'm in the UK, no pilot assist/ACC, just basic cruise & speed limiter.
 

·
Registered
Joined
·
13 Posts
I got similar issues. The active cruise control stopped working for no reason on a freeway trip. However, after the trip, a few days later, I found the car's hood was not correctly closed/locked on the left side (if you face the car from the front). I re-closed the hood and made sure it's fully closed/locked. Now the cruise control comes back. Not sure if it's really because of that, but worth trying.

I guess the reason is the unlock handle is on the right side, so I tend to push on the right side of the hood to close it.
 

·
Registered
XC40 P8 Recharge 2021
Joined
·
8 Posts
Discussion Starter · #3 ·
The cruise control still works, it's just there's no icon to say it is enabled but not active. I'm trying the "leave it for 24 hours" fix. I've also email Volvo to see if it part of the s/w "upgrade".
 

·
Registered
Joined
·
48 Posts

From reading the list of June updates it appears that Pilot Assist was changed. It looks like this also affected cruise control.
 

·
Registered
Joined
·
262 Posts
I don't recall seeing a feature called Speed Limiter. Is this replaced by Pilot Assist if you get the advanced package? Or maybe a UK/EU vs US thing? Or maybe I just missed it...
 

·
Registered
Joined
·
242 Posts
I got similar issues. The active cruise control stopped working for no reason on a freeway trip. However, after the trip, a few days later, I found the car's hood was not correctly closed/locked on the left side (if you face the car from the front). I re-closed the hood and made sure it's fully closed/locked. Now the cruise control comes back. Not sure if it's really because of that, but worth trying.

I guess the reason is the unlock handle is on the right side, so I tend to push on the right side of the hood to close it.
You shd use two hands to close hood each about a quarter way in from outer edges. If you only put pressure on one side you could have what happened to you with only one side latching and or accidentally bending the hood.
 

·
Registered
Joined
·
13 Posts
You shd use two hands to close hood each about a quarter way in from outer edges. If you only put pressure on one side you could have what happened to you with only one side latching and or accidentally bending the hood.
Exactly. I was just following my old habit to push wherever the unlock handle is located.😓
 
1 - 9 of 9 Posts
Top