Volvo XC40 Forum banner

41 - 60 of 76 Posts

·
Registered
Joined
·
32 Posts
Yesterday went for a short drive - and noticed that in the drivers display the map view was frozen at our home address and neighbourhood view no matter where i drove - have not had that before - even toggling thru the different driver display views did not un-freeze the map view - will check to see if it fixed itself today - if not may have to do a reset that I have read about in the forum.
This also happened to me about four days ago. I thought I was having the "searching for GPS issue" again (have had that twice already), but the nav on the centre screen was still working. Rebooting the centre screen fixed the issue for me.
 

·
Registered
2021 Volvo XC40 Recharge
Joined
·
18 Posts
This also happened to me about four days ago. I thought I was having the "searching for GPS issue" again (have had that twice already), but the nav on the centre screen was still working. Rebooting the centre screen fixed the issue for me.
Thanks. Will try that.
 

·
Registered
Joined
·
188 Posts
Aah you need an update!!!
Has an appointment at the dealer today - got a software update:
760

Looks like it is the same as yours now. Drivers Display now shows the map - so that is good - A/C is still intermittent - when cooler temps seems to work well - when 90 plus degrees does not work will have to call dealer again.
 

·
Registered
Joined
·
188 Posts
90 degrees F today in southern Ontario - took the car for a drive to Niagara falls - about 30 mile round trip 5 minutes in A/C set at 64 degrees F and just blowing warm air - do not have heat pump option - Climate set to Auto - shows A/C is on - any thoughts on what could be wrong? Car was sweltering half way through - had to ride with the windows open the rest of the way - felts like we were back in the 50's when A/C was only for the rich and famous!!
Went to the dealer today - service manager stated that Service Action S10011 - was only for Mid year 2020 ICE XC40's - got the latest software update - supposed to help with A/C working better in Higher temps - 90 degrees today on the way home and A/C just blew warm air - so software did not fix the issue - has anyone else had this issue? - will have to contact the dealer service dept and make another appointment to see what needs to be done to fix - seems to be intermittent - when Temps in the 70's and low 80's no issue it works - when in the high 80's and low 90's just blows warm air.
 

·
Registered
Joined
·
96 Posts
We're into the 90s here in Sacramento, and mine seems to do quite well cooling the car. I don't think it's quite as strong as my past cars but i suspect that's more an energy saving aspect. At any rate, after a couple of minutes it's quite comfy. It would be nice to have the VOC preconditioning working though.
 

·
Registered
Joined
·
90 Posts
Low 90s in midwest. Most of my trips are less than 45 minutes but car is cool. temp set to 66 and air out of the vent is very cold. Similar to standard ICE AC.
 

·
Registered
Joined
·
92 Posts
Has an appointment at the dealer today - got a software update:
View attachment 760
Looks like it is the same as yours now. Drivers Display now shows the map - so that is good - A/C is still intermittent - when cooler temps seems to work well - when 90 plus degrees does not work will have to call dealer again.
This is the version I have as well.
Is there a newer version than this?
My P8 is at the dealership tomorrow for a front window tint install, so would love them to get me to the latest SW if there’s an update available. I had the guy in the service dept check and he didn’t find any available updates.
 

·
Registered
Joined
·
4 Posts
Today, when I got into my xc40 P8, I realized that there is no GPS signal, no car modem internet, no wifi. Rebooted the system couple of times. No luck. Powered off the vehicle. No change. Reset all networks. Didn't help. Call my dealership. They told me to come in right away. They could not connect to the car. They did a factory reset. Still did not help. Tomorrow they will contact Volvo Canada for a solution. Will keep you updated...
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #51 ·
Volvo Canada said, we are aware of these issues, wait for the update. Right now the only solution I found is, leave the car in peace and charge it. Most problems get resolved the next day by itself. I love my p8, it has its own character.
 

·
Registered
Joined
·
4 Posts
Got my vehicle 2 months ago. Same issue as reported; no LTE and no GPS available yesterday.Called my dealership who suggested making an appointment for an update. Before making the appointment, I read every single comment of this post. Here's what worked for me. First: pressed and held down the defrost button for 20 seconds (to reboot modem). Second: turned off car (exit and locked all doors) and proceeded to a full charge WITHOUT interruption. I had already done the press and hold during the day but interrupted the charge to go run some errands and the problem persisted. The difference between both times is that I let the battery charge fully prior to disconnecting.
 

·
Registered
Joined
·
188 Posts
Volvo Canada said, we are aware of these issues, wait for the update. Right now the only solution I found is, leave the car in peace and charge it. Most problems get resolved the next day by itself. I love my p8, it has its own character.
last 2 days I had no Network LTE connection and would not connect to my wifi - this morning it connected to both no problem - perhaps they had the system turned off to do some programing or Maintenance.
So hopefully it will last 24 hours so I can see if VOC works and loads info for SOC and climate pre-conditioning - all it would do before is lock and unlock - this became available when version 5.0 of the app was released.
 

·
Registered
Joined
·
517 Posts
Wait there is a reset for the modem but I do k no it remember it.

Someone please link how to reset the lte.

I agree with you about them having a character. Wife(1) says I should stand outside the car while they park when it’s quiet so I can here the cars alien purring sounds :)
 

·
Registered
Joined
·
517 Posts
Driving around today when the car lost the internet … this was a good reminder that I needed to program the car to see my phones WiFi hotspot. Got that up and running. After 15 mins I decided to test the cars connection to the internet and it was back.

A suggestion while everything is working switch on your phones WiFi hot spot. Connect your car to the hot spot. Now turn it back off. Ow when it goes south at a bad moment you can easily switch back to your phones.
 

·
Registered
Joined
·
278 Posts
US P8 owner - good luck. We have had major wifi connection issues at home (no wifi recognition). Dealer checked wifi out and said it was working fine. Contacted customer service and had no further update. System may prefer a Google wifi router or wifi card in vehicle has problem recognizing non-Google wifi routers. Overall, extremely poor customer support on this new vehicle in the Volvo family. Lifetime Volvo owner - very disappointed. However, the car is great!
Until today, not able to get connected to home WIfi -- even fiber optics, with dual bands - so something's off there. Forget about inquiring with Dealer! I bet someone from the Forum will have the answer(s) first !
 

·
Registered
2021 Volvo XC40 Recharge
Joined
·
18 Posts
“Until today” suggests that you are now connected to WiFi? Is WiFi detected by your phone or other device where the car is located?
 

·
Registered
Joined
·
278 Posts
“Until today” suggests that you are now connected to WiFi? Is WiFi detected by your phone or other device where the car is located?
To clarify, no....no WIFI connection as of yet. All cell and home devices are connected to WIfi with highest level of signal. It could recognize perhaps 2 of Neighbours signal...and intermittently break connections with another 2....I DID notice that the one option that remains available is "Stardust 2G" -- which makes me wonder perhaps it only works with 2G ? Cannot be right ?
 
41 - 60 of 76 Posts
Top