Volvo XC40 Forum banner
1 - 6 of 6 Posts

·
Registered
2021 White XC40 Recharge P8
Joined
·
226 Posts
Discussion Starter · #1 ·
I was poking around the Google Play Store and clicked on the gear icon at the top right of the window. In looking at my devices I was surprised to see that for the devices listed the carrier was different.
1199


I only have one phone paired with my P8. The device registered on 5/15/21 was my initial attempt to pair my phone. Like most owners experienced the phone paired with the vehicle but the app didn’t work at all and finally landed in an error state. The device registered on 6/29/21 was my 2d attempt after doing a factory reset. Since this pairing the VC app has “worked”. I have not tried to delete the 5/15 device because the VC app is working and I didn’t want to risk screwing up the status quo.

I remember reading that T-Mobile is the carrier for the P8’s LTE HW in the US . The carrier for my cell phone is AT&T. I’m surprised to see both devices shown as being used, with the 5/15 device being the most recently used device. Crazy!
 

·
Registered
Joined
·
428 Posts
I wouldn't expect this device list to reflect your PHONE's carrier at all - I think it should show the carrier that the CAR is using for its LTE connectivity. We know our P8s have a "Google" data plan - and Google has been using T-Mobile and US Cellular towers. Perhaps Google has started using AT&T towers as well? Or maybe your car was "roaming" to AT&T when you set up this second pairing?

My P8 paired successfully the first time back in May (although it just started working reliably a few weeks ago). My device list still shows T-Mobile as carrier.
 

·
Registered
2021 XC40 Recharge
Joined
·
154 Posts
I believe that the table of devices seen in your screenshot has nothing to do with the Volvo cars app on the phone. Rather, it is just a list of the built-in Google assistant software connections.
Could it be that the new entry might be when/if you tried signing into google assistant while using your phone as a hot spot?
 

·
Registered
Joined
·
1,138 Posts
It should be showing you the Google Android device built into the car. Has nothing to do with any phone you have paired. I would expect the carrier to be directly tied to the SIM in the car. Unless they ported some SIMS to ATT
 

·
Registered
Joined
·
428 Posts
It should be showing you the Google Android device built into the car. Has nothing to do with any phone you have paired. I would expect the carrier to be directly tied to the SIM in the car. Unless they ported some SIMS to ATT
That's what I've thought, too - tied to the car's SIM. But since the car's SIM is actually for an NVMO ("virtual carrier") aka Google - perhaps it reflects whatever carrier tower the car was actually using when you linked your Google account with the car. Google plans normally use T-Mobile towers here in the US, but I think they can roam to AT&T if needed.
 

·
Registered
2021 XC40 P8 - Thunder Grey
Joined
·
47 Posts
My original P8 (ended up getting it swapped for another vehicle due to dead A/C system) is listed in my google account as T-Mobile, while my replacement P8 is listed as AT&T.
 
1 - 6 of 6 Posts
Top