Volvo XC40 Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
We took delivery of our P8 early this past week. On multiple occasions, the car seems to lose all sense of network connectivity: none of the apps will load remote content properly, the On Call app cannot talk to the car, and Google Assistant doesn't work. (Maps have been downloaded for offline use.) This will resolve itself randomly. Resets of the modem have been tried, and sometimes it helps, but sometimes it doesn't. It's very aggravating: a big part of why we bought a P8 was the connected services, and finding that they don't work is frustrating.

The dealership is looking into the issues for us, but I'm wondering what the community has experiences on this front.

I'm given to understand that, in Canada at least, the P8s are roaming on a T-Mobile network connection. Could this be part of the issue?
 

·
Registered
Joined
·
125 Posts
We took delivery of our P8 early this past week. On multiple occasions, the car seems to lose all sense of network connectivity: none of the apps will load remote content properly, the On Call app cannot talk to the car, and Google Assistant doesn't work. (Maps have been downloaded for offline use.) This will resolve itself randomly. Resets of the modem have been tried, and sometimes it helps, but sometimes it doesn't. It's very aggravating: a big part of why we bought a P8 was the connected services, and finding that they don't work is frustrating.

The dealership is looking into the issues for us, but I'm wondering what the community has experiences on this front.

I'm given to understand that, in Canada at least, the P8s are roaming on a T-Mobile network connection. Could this be part of the issue?
Try bluetooth tethering.
 

·
Registered
Joined
·
16 Posts
Assistant doesn't work. (Maps have been downloaded for offline use.) This will resolve itself randomly. Resets of the modem have been tried, and sometimes it helps, but sometimes it doesn't. It's very aggravating: a big part of why we
I have this issue in the USA. Every few days the LTE signal strength icon at the top of the center display shows an X and there is no connectivity. I called the dealer and they aren’t aware of a widespread issue. The only solution that works so far is to reboot the infotainment system by holding down the button immediately below the center display. It’s very annoying.
 

·
Registered
Joined
·
3,672 Posts
Had this happen once. I set up tethering (in my case WiFi) to cover this happening but it sounds like you have something faulty going on as it should not be failing all the while.

Get the dealer to diagnose your system / replace parts.
Good luck. Let us all know how it goes.
 

·
Registered
Joined
·
2,416 Posts
I have this issue in the USA. Every few days the LTE signal strength icon at the top of the center display shows an X and there is no connectivity. I called the dealer and they aren’t aware of a widespread issue. The only solution that works so far is to reboot the infotainment system by holding down the button immediately below the center display. It’s very annoying.
I will be honest, I like T-Mobile as a disrupter in the industry, but have never had good luck with their cell service. T-Mobile is the provider in the US and they have their hands full with 5G and Sprint integration and migration. Maybe in 3-5 years they will be on parity with ATT and VZ, but not now.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
So following my original message: our car went in for servicing and had the newest software update applied. Everything appeared to be working that afternoon and into the evening. The next morning, the LTE was once again inoperative, and the GPS receiver was offline too. We also discovered a number of other, new problems:
  • The climate preconditioning timers were inoperative. None of the timers I had set were visible, and it was impossible to set or save new timers.
  • The charging limit had gone from 90% to 100% with no apparent way to change this (i.e., moving the slider did nothing, with the instrument panel continuing to show 100% as the limit).
  • The car could no longer see or connect to any WiFi networks.
Two days later, the LTE and GPS suddenly came back to life, as did the climate timers -- only the timers didn't actually do anything. The charging limit continues to be set at 100% regardless of what the touchscreen says. Connectivity appears to be better, though.

What a frustrating mess.
 

·
Registered
Joined
·
2,416 Posts
I am beginning to think maybe I tell dealer not to put the software update on as my software seems decent.
 

·
Registered
Joined
·
3,672 Posts
That’s where I am at. Everything works. The new software is not offering anything new so ….
 

·
Registered
Joined
·
2,416 Posts
Yeah I am ready to bail on software update and ever having VOC paired or working. The principal to me is they sold us a car that has certain features and have not delivered. Dealers need to cough up the $750 and make it up to us. Dealer did not say of yeah, give me $60K and by the way some of the thing listed do not work yet.
 
  • Like
Reactions: ChicagoFlyer

·
Registered
Joined
·
3,672 Posts
At least we also got 7500 back from the government for being on a beta ( as the deal goes away as the manufacturer gets better and has done more evs).

I think by winter that voc will work. And I look forward to it :)
 

·
Registered
Joined
·
100 Posts
I started having issues with the data connection today. When I ask Google for directions, a beeping sound and a recorded message say that the internet connection is unreliable. I kept trying it at different locations and still kept getting the same message. After I restarted the modem by holding down the defrost button, it seems to be working again.
 

·
Registered
Joined
·
2,416 Posts
At least we also got 7500 back from the government for being on a beta ( as the deal goes away as the manufacturer gets better and has done more evs).

I think by winter that voc will work. And I look forward to it :)
True, but considering my wife’ T5 almost identically equipped was $14K less not sure that helps much. Now I have HK and rear spoiler so real difference is more like $12.8K then subtract $7500 beck’s,e more like $5500 premium for the P8. Now depending on how much you drive will dictate when the gas savings makes the P8 a better value. And of course there is no way to put a number on the increase in HP and torque and fun factor. And her T5 has been flawless so far.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top