Volvo XC40 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
We picked it up on Saturday.

The Infotainment system crashed 3 times, typically turning a solid color and the center of the dash display would also turn it's own solid color (on Navigation mode at least.) It also crashed a couple of times yesterday.

At one point we got an error message in the center display but clicked through it before taking a picture. This vehicle is running the latest software. Has anyone else had this issue?
 

·
Registered
Joined
·
49 Posts
We picked it up on Saturday.

The Infotainment system crashed 3 times, typically turning a solid color and the center of the dash display would also turn it's own solid color (on Navigation mode at least.) It also crashed a couple of times yesterday.

At one point we got an error message in the center display but clicked through it before taking a picture. This vehicle is running the latest software. Has anyone else had this issue?
I had a similar situation. I linked the ONCALL app with the keys and the problem seemed to disappear.

The app doesn't have full car functions, but for some odd reason, after linking it, everything resolved.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 · (Edited)
Cool I will give that a try. We currently have 2 profiles, the primary (admin) is linked to the valet key and a secondary account is linked to key 1. I will try adding key 2 to the primary and see if that helps.

Edit: I didn't realize you could only link a single key to a profile. I will ask my wife to swap out the valet key for a real one and see if that helps.
 

·
Registered
Joined
·
1 Posts
I have the same problem on my XC40 Recharge in Germany. During about 1000 miles the system crashed 9 times. A software reload last Friday did not help.
 
1 - 6 of 6 Posts
Top