Volvo XC40 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
This morning my infotainment system blacked out, while its not the first time - it happens so sporadically i thought nothing of it... However right after it came back to life (under 30 seconds), luckily while i was at a stop light the engine cut out - stalled. That had never happened before. I was at an incline so if i had taken my foot off the break it would have rolled (so i was in neutral). I started the car and was relieved that it restarted, the radio went on right away the infotainment a little slower. when the light changed i found myself in park bc the car somehow reset at some point when i restarted.

I called the dealership once i got into work and taking it in tomorrow morning to be checked out.
 

·
Registered
Joined
·
1 Posts
This morning my infotainment system blacked out, while its not the first time - it happens so sporadically i thought nothing of it... However right after it came back to life (under 30 seconds), luckily while i was at a stop light the engine cut out - stalled. That had never happened before. I was at an incline so if i had taken my foot off the break it would have rolled (so i was in neutral). I started the car and was relieved that it restarted, the radio went on right away the infotainment a little slower. when the light changed i found myself in park bc the car somehow reset at some point when i restarted.

I called the dealership once i got into work and taking it in tomorrow morning to be checked out.
Yesterday, I had the same thing happen twice in a row after stopping at traffic lights. I had turned on the Auto-hold brakes while waiting for a gas pump and turned the Auto-hold off after leaving the gas station. As I approached the first stop light afterward, the infotainment screen flashed and then went blank followed by the car stalling. It took 3 tries to get it restarted at the first light. The next light I stopped at it did the same thing but started again on the first try.

Did you also have the Auto-hold on when this happened to you?

What was the fix at the dealership?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Yesterday, I had the same thing happen twice in a row after stopping at traffic lights. I had turned on the Auto-hold brakes while waiting for a gas pump and turned the Auto-hold off after leaving the gas station. As I approached the first stop light afterward, the infotainment screen flashed and then went blank followed by the car stalling. It took 3 tries to get it restarted at the first light. The next light I stopped at it did the same thing but started again on the first try.

Did you also have the Auto-hold on when this happened to you?

What was the fix at the dealership?
I am not sure if my auto hold is on or not. I don’t frequently use that button. It’s either always on or off. Prob on.

the dealership said there was a big software update they pushed thru. It took an hour to load (I recently had one load in nov when I had an oil change). They said there weren’t any codes that were thrown that specified the stall.
 
1 - 3 of 3 Posts
Top