Volvo XC40 Forum banner
161 - 180 of 213 Posts

·
Registered
Joined
·
7 Posts
After several failed attempts, the only thing that convinced them to change the IHU was pictures of all the colours when it crashed. I described this several times to the service people, but kept coming back with "software update".

I showed the pictures to the technician at my dealership. I could see his console with Volvo for support, which came back straight away with "replace IHU" and it was ordered. Coming this week fingers crossed!

They need to see it with their own eyes to understand the issue!
 

·
Registered
Joined
·
1,328 Posts
After several failed attempts, the only thing that convinced them to change the IHU was pictures of all the colours when it crashed. I described this several times to the service people, but kept coming back with "software update".

I showed the pictures to the technician at my dealership. I could see his console with Volvo for support, which came back straight away with "replace IHU" and it was ordered. Coming this week fingers crossed!

They need to see it with their own eyes to understand the issue!
Good job on teaching them and sharing hear as others have how to present to your dealership the problem. It is sad that we seem to know more about the P8 than many of the dealerships but it is what it is. At least yours listened. :)

Hopefully it will be back soon and you can enjoy the car for the wonder that it is.

I wonder if there will be a selective recall if they can work out a pattern / make of IHU failure.

Cheers and grats
 

·
Registered
Joined
·
934 Posts
I found that driving your issues through dealer and Volvo Customer Care helps.I had Volvo involved before the dealer so that Volvo reached out to the dealer when I made my appointment and the dealer was very engaged at that point and knew Volvo was involved. On my previous visits the dealer was than than helpful, but once I had Volvo I Volvo and then worked directly with Service manager (instead of their front line advisors) things went well. It has been a month and new IHU, rotors and pads have been great. I did have to do a hard reboot the other day due to very laggy infotainment.

if I find the time I may start folllwoing some XC60 forums as the 22 has this Android OS now and I can’t wait to see how Volvo deals with more users with issues in their main stream car.
 
  • Like
Reactions: Ces

·
Registered
Joined
·
1,328 Posts
Maybe they will deal with more users by fixing stuff :)
I know optimism in 2021 feels almost dirty to be optimistic :)
 
  • Like
Reactions: Greg S

·
Registered
2021 Thunder Gray XC40 Recharge
Joined
·
6 Posts
Just was informed that the dealer has a replacement IHU on order and should have it available in a “few days”.

we shall see, but it is a step in the right direction
 

·
Registered
Joined
·
934 Posts
I am curious as to what the issue has been, just bad product, design change, etc.
 

·
Registered
Joined
·
26 Posts
It's funny to me that everyone who experiences this issue has to deal with the service people the same way. They always try telling us they'll fix it through a software update when we can insist that they won't be able to. When they finally listen to us, it works. If only we could have them read through this thread before wasting everyone's time with software updates.
 

·
Registered
2021 XC40 Recharge
Joined
·
7 Posts
It's funny to me that everyone who experiences this issue has to deal with the service people the same way. They always try telling us they'll fix it through a software update when we can insist that they won't be able to. When they finally listen to us, it works. If only we could have them read through this thread before wasting everyone's time with software updates.
Just to give a positive shout-out to my dealer's service team at Wynne Volvo in Hampton (VA), I provided photos of several instances of the colored "crashed" infotainment display and a link to this thread, and I didn't get any pushback on the IHU replacement. I had the vehicle back six days after dropping it off. No issues since the replacement.
 

·
Registered
Joined
·
934 Posts
Got my car back today with a new IHU. Just took them a morning to fit it. Fingers crossed all is now well.

They also put on an August software update, not yet managed to see what's new with this.
I have had mine back just over a month, no more reboots or blotches. I do have to force a reboot every so often due to lagginess and Spotify not accepting the pause button. Still very disappointed in the buginess of AAOS and the apps, even my Android phone is more reliable.
 

·
Registered
Joined
·
7 Posts
I have had mine back just over a month, no more reboots or blotches. I do have to force a reboot every so often due to lagginess and Spotify not accepting the pause button. Still very disappointed in the buginess of AAOS and the apps, even my Android phone is more reliable.
That stuff is really annoying but I hope they can fix it with the OTA updates.

As long as I never see one of those bright colours again I'll be happy.

Looks like this has been a costly episode for Volvo, those new IHUs don't come cheap, particularly given the global chip shortage. Let's hope lessons have been learnt. I'll be there to part exchange for a fully electric XC60 when the time comes, but this time I might wait a few months before taking the leap!
 

·
Registered
Joined
·
934 Posts
It is very frustrating. I get software has bugs, been in IT for over 35 years, but this level of issues and incompleteness is just not acceptable. I know all EVs are going through this, but this is how companies loose customers. Not to mention the word of mouth. I will be honest, I read these forums before buying and was a slight hesitant, if I were reading them now I might deicide to hold off and see if Volvo follows through with this stuff.
 

·
Registered
2021 XC40 Recharge
Joined
·
16 Posts
So my less than a week old Recharge has lost connectivity randomly yesterday. I've tried the defroster reset as well as a hard reset and nothing works. Called Volvo and they said if a reset didn't fix it to call the dealer. I haven't had any error messages or weird screens. Just no GPS or internet connection, and the car won't see wifi networks either.
 

·
Registered
Joined
·
1,328 Posts
So my less than a week old Recharge has lost connectivity randomly yesterday. I've tried the defroster reset as well as a hard reset and nothing works. Called Volvo and they said if a reset didn't fix it to call the dealer. I haven't had any error messages or weird screens. Just no GPS or internet connection, and the car won't see wifi networks either.
Sorry to hear that.

It will probably be working in the morning.
Often gps WiFi and lte all go down together. A nice nap and it should be as good as new. Mine has done this twice since May.

Let us know if it resolves after the car has a nap.
Good luck
 

·
Registered
2021 XC40 Recharge
Joined
·
16 Posts
It actually stopped working last night. I saw some posts saying it might come back after a few hours. Still out this morning. I'm waiting on a call back from my dealer.
 

·
Registered
Joined
·
1,328 Posts
Downer. Normally comes back the next day.
well good luck at the dealer.
 

·
Registered
Joined
·
77 Posts
the one time this happened to me, connections came back after 24-48 hours with car parked in my driveway. I think maybe the systems do some sort of reboot…

So my less than a week old Recharge has lost connectivity randomly yesterday. I've tried the defroster reset as well as a hard reset and nothing works. Called Volvo and they said if a reset didn't fix it to call the dealer. I haven't had any error messages or weird screens. Just no GPS or internet connection, and the car won't see wifi networks either.
 

·
Registered
Joined
·
124 Posts
So my less than a week old Recharge has lost connectivity randomly yesterday. I've tried the defroster reset as well as a hard reset and nothing works. Called Volvo and they said if a reset didn't fix it to call the dealer. I haven't had any error messages or weird screens. Just no GPS or internet connection, and the car won't see wifi networks either.
Our car has had this problem as well (required the dealer to do some sort of "deep reset" which probably involved unhooking the 12 V battery?) because a module was in "deep sleep" and wouldn't wake up.
Waiting overnight didn't help and the defroster button didn't appear to do anything either, which still bugs me.
 

·
Registered
2021 XC40 Recharge
Joined
·
16 Posts
Our car has had this problem as well (required the dealer to do some sort of "deep reset" which probably involved unhooking the 12 V battery?) because a module was in "deep sleep" and wouldn't wake up.
Waiting overnight didn't help and the defroster button didn't appear to do anything either, which still bugs me.
This is good info I'll send it to my dealer. Thanks
 
161 - 180 of 213 Posts
Top