Volvo XC40 Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Am having range issues with HomeLink. When I am in the garage within 10’ of the opener it works. But nothing from outside even if my front bumper is again the door. The handheld remote works fine.

I’ve cleared out the first installation by pressing the 2 outer buttons until appropriate lights flash the reinstalled. Same result

Talked with Volvo CS but they quickly sent me to HL CS. Went through all their recommended steps including initiating an install using the install button on the door opener itself.

Final suggestion from HL was to install a range extender on the door opener. Anyone else having similar problems and more important did you find a solution?

In the big scheme of things this is minor and I love the car.
 

·
Registered
Joined
·
2 Posts
I'm afraid that I don't have any suggestions as to how to fix your issue but I can confirm that the HomeLink in my XC40 works fine 30' to 40' away from the garage door. I don't understand why you would need a range extender.
 

·
Registered
2021 XC40 P8 - Bursting Blue
Joined
·
257 Posts
Works well for me, my driveway is about 100' long and I push the button before even turning in.

Perhaps your garage door opener's receiver is suboptimal?
 

·
Registered
Joined
·
1,697 Posts
My home link works flawlessly from inside or outside the garage. The range is better than the little dongle I used to use.

Obvious question but how well does your dongle work outside the garage ?

If dongle works properly then I would guess there is something faulty in the signal strength from the car and dealer is fobbing you off with a get an extender talk.
 
  • Like
Reactions: sbixby

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
Yesterday afternoon I drove into the driveway and thought I’d try the garage door opener. Guess what - it worked perfectly. As far as I can tell I’ve changed nothing. I’ll accept the improvement and thank whomever.
 

·
Registered
Joined
·
1,697 Posts
Your P8 had time for a good nap …. Napping seems to fix a lot of things (cold reset) had k no ot heard of it helping the garage opener but … why not :)

glad it worked for you.
 

·
Registered
Joined
·
19 Posts
Check your opener. Certain LED interferes with the antenna. Change it to an old school incandescence bulb and see if it helps(or remove the LED bulb if you are using one)
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #9 ·
Check your opener. Certain LED interferes with the antenna. Change it to an old school incandescence bulb and see if it helps(or remove the LED bulb if you are using one)
Thanks. About 4 days after I posted this it started working. Not sure what happened as nothing changed. But I happy it works.
 
1 - 9 of 9 Posts
Top