Volvo XC40 Forum banner
1 - 20 of 23 Posts

·
Registered
2021 XC40 P8 - Bursting Blue
Joined
·
256 Posts
Discussion Starter · #1 ·
Has anyone experienced this message showing in the consoles? I've seen it twice since I picked it up on Wednesday evening -- that evening and again last night. I think this occurred when I switched the lights on in my semi-dark garage.

I forget the exact text but something like "Detected a headlight malfunction". It shows up in the vehicle status screen on the center console. And then it seems to go away on it's own.

Both times, the headlights seemed fine; the high/low beams work, and the left-right actuation while driving also worked.

Anyone else?

Side note: I was thinking about starting a sticky "Bug List" topic where we can track all these issues in hopes of finding commonalities and being able to get Volvo to look at them. I think I might be moderated on editing posts, I tried to update one for a minor typo and it's showing as "waiting for moderation".
 

·
Registered
Joined
·
170 Posts
I had that warning appear once after going through a car wash.
As you noted, all headlight functions appeared to work.

It self cleared when I turned the car off and restarted the car.

I believe it is a glitch in the active bending headlights.

It has not recurred.
 

·
Registered
Joined
·
1,678 Posts
No and I do not want to!!!

Sorry your having that. How they fix it soon.
 

·
Registered
Joined
·
19 Posts
I had that one last week and the service department said that the upcoming software update would fix.
 

·
Registered
2021 XC40 P8 - Bursting Blue
Joined
·
256 Posts
Discussion Starter · #6 ·
I saw it twice, then no further for 8+ days. <knock on wood>
 

·
Registered
Joined
·
7 Posts
Another for the “headlight malfunction” tally. They seemed to be fine. Went away on its own.
 

·
Registered
Joined
·
1,678 Posts
Did you do anything to make them go away or did they just go away? I hate intermittent faults. Is there anyway to feed this back to Volvo in case there is a pattern?
 

·
Registered
2021 XC40 P8 - Bursting Blue
Joined
·
256 Posts
Discussion Starter · #10 ·
I'm still getting this, periodically. Virtually always when starting out from my garage or entering my garage and the headlights come on. Maybe 1 out of 5 times.

So -- still wondering if it's software or an actual fault in the headlamp system. Any other ideas?
 

·
Registered
Joined
·
1,678 Posts
The other part of the trifecta is sensor error.

Could be a faulty sensor?
 

·
Registered
2021 XC40 P8 - Bursting Blue
Joined
·
256 Posts
Discussion Starter · #12 ·
The other part of the trifecta is sensor error.

Could be a faulty sensor?
A reasonable guess. I'm reluctant to take it to the dealership yet in case it is indeed a software issue. I'm waiting for the/an OTA update, if it's coming. I'm working at home today so the car is in the garage (on Wifi tho), dunno if I'd be getting it yet or not. (Or even if I'm misunderstanding posts about it from today, actually.)
 

·
Registered
Joined
·
123 Posts
My Model 3 threw the same intermittent message during its early days, no hardware problem - eventually fixed by software update.
 

·
Registered
Joined
·
80 Posts
These two error messages showed up today. Will take it to the service dept tomorrow and see what they have to say.

1027
1028
 

·
Registered
Joined
·
1,678 Posts
Oh fun times! (Sarcasm)
Hope they fix it quick.
Be glad when they get P8 loners :)
 
  • Like
Reactions: Seattleman

·
Registered
Joined
·
170 Posts
This error code appears to be universally common in virtually all makes of cars using headlights that align and use LEDs. It seems to be a problem with how the headlight sensors report information back to the main car information system. Many people have "hacks" that bypass the sensor as this problem is so frequent.

People in this forum have reported this error. In my case, it appeared once about two weeks into car ownership. It disappeared the next morning and has never recurred over the past two months.

I would be curious if it isn't gone on the next car restart.

As cars have more sensors and more electronics, this kind of sensor error may be more common.

I do agree with SeattleCat that many of the issues that are being posted are due to the increasing technological demands and expectations of the electric car driver. Many of these issues do seem to self resolve on a reboot or cold restart.

In my case, the most annoying problem was the AC failure. This was fixed with the software upgrade.
 

·
Registered
Joined
·
80 Posts
I agree, that most of the error messages related to this car are software related and like many software issues, a restart fixes most of them. A few weeks ago, while I was driving, the driver display showed the image of a turtle and warned of low battery even though the car battery was 70% full. When I took the car to the dealership service dept, I was told that they have one person who is qualified to work on this issue and so I will have to leave the car there for a few days. He also suggested that since the error message did not occur again, to keep using the car and come back if the problem persists. To this day, it has not come back.🤞
 

·
Registered
Joined
·
609 Posts
I love how the default statement (with confidence) and conclusion by Service is ".....the next software update will fix it...."
 

·
Registered
Joined
·
1,678 Posts
Even better when they claim that they are going to do a software upgrade when you know **** well there is. It another out and it will have the same software after the service :)
 
1 - 20 of 23 Posts
Top