Volvo XC40 Forum banner
1 - 20 of 25 Posts

·
Registered
2021 XC40 Recharge
Joined
·
111 Posts
Discussion Starter · #1 ·
My first problem with this car, today while on highway I could not engage cruise control, it said "not available" even though I had the lane markers at the top of drivers screen. I pulled off highway and reset IHU and checked for any blockage (dirt, etc) in front of cameras on top of windshield and radar on front grill and found nothing, locked the car and walked away for 5 mins but no luck.

Anyone else have this problem or suggestion?
 

·
Registered
2021 XC40 Recharge
Joined
·
111 Posts
Discussion Starter · #3 ·
Was your foot on the accelerator? ACC won't engage if you are actively accelerating.
I was holding my speed like I normally do and tried to engage numerous times but all I got was "not available"
 

·
Registered
Joined
·
1,376 Posts
Was your foot on the accelerator? ACC won't engage if you are actively accelerating.
You can engage cruise control while actively accelerating (just tried it to make sure).

What software build do you have?
On that note it is handy to add build info to signature so that people can more accurately help you.

Was your acc set to steering assist as well?
 

·
Registered
2021 XC40 Recharge
Joined
·
111 Posts
Discussion Starter · #5 ·
I have the latest software, same as yours normally called June update and my steering assist has been turned off since I picked this up end of June. I have had no problems with cruise control which I use often until yesterday.
 

·
Registered
Joined
·
279 Posts
I have the latest software, same as yours normally called June update and my steering assist has been turned off since I picked this up end of June. I have had no problems with cruise control which I use often until yesterday.
Pilot assist is not on the main infotainment screen under driving. Can be toggled on and off on that screen.
 

·
Registered
2021 XC40 Recharge
Joined
·
111 Posts
Discussion Starter · #7 ·
Pilot assist is not on the main infotainment screen under driving. Can be toggled on and off on that screen.
Well after leaving it alone over night it decided to work today after I cleaned the windshield camera area and forward camera in the Volvo emblem (even though it was clean) and recycled every switch I could find related to driver assist, Now I'm not sure what helped or if just leaving it over night was the cure.
 

·
Registered
Joined
·
110 Posts
You can engage cruise control while actively accelerating
That's not true in all cases. I've been accelerating on the highway, and pressed the resume button a bit prematurely, and it has indeed said 'not available'. I back off the accelerator and it takes. The difference may be using the resume button after ACC is initialized, rather than doing an initial startup of ACC with the center button.
 

·
Registered
Joined
·
1 Posts
My first problem with this car, today while on highway I could not engage cruise control, it said "not available" even though I had the lane markers at the top of drivers screen. I pulled off highway and reset IHU and checked for any blockage (dirt, etc) in front of cameras on top of windshield and radar on front grill and found nothing, locked the car and walked away for 5 mins but no luck.

Anyone else have this problem or suggestion?
Hi,
Today I got the same problem, "Not available". It has been working fine up till now. Not fun. Incredibly weak for a "premium" car.
Magnar Bakke, Skien, Norway
 

·
Registered
2021 XC40 Recharge
Joined
·
111 Posts
Discussion Starter · #10 ·
Hi,
Today I got the same problem, "Not available". It has been working fine up till now. Not fun. Incredibly weak for a "premium" car.
Magnar Bakke, Skien, Norway
Wish I could tell you what to do but the usual suspect is dirty windsheild or dirty camera lens in front Volvo logo. Bet you it works fine tomorrow!
 

·
Registered
Joined
·
6 Posts
This is kinda peculiar, because I've also had the same "Not available" error for the first time today - running the June update for a few weeks now, and have never had a problem with it engaging cruise control before now.

Front camera and the front-facing sensors by the rear mirror are clean and debris-free. Tried the usual "fix everything" technique of resetting the center console, which unsurprisingly did nothing, but was worth a go. Now just onto hoping it just mysteriously works when I try again tomorrow.
 

·
Registered
Joined
·
157 Posts
Cruise control is adaptive and requires the front radar sensor be clear of debris and functioning.

The radar sensor is behind the front window.

The Volvo manual notes that cruise control comes in two modes. If the adaptive mode is turned off, the radar is not needed and cruise control will work.

The adaptive cruise control cannot be activated.
This could be due to:
  • brake temperature is high
  • the radar sensor is blocked by e.g. wet snow or rain.
For more information about fault tracing, see section Fault tracing and action

The adaptive cruise control is temporarily disengaged.
  • The radar sensor is blocked and cannot detect other vehicles. For example, in the event of heavy rain or if slush has collected in front of the radar sensor.
The driver can then choose to switch to normal Cruise control (CC)
 

·
Registered
Joined
·
609 Posts
You can engage cruise control while actively accelerating (just tried it to make sure).

What software build do you have?
On that note it is handy to add build info to signature so that people can more accurately help you.

Was your acc set to steering assist as well?
That's not true in all cases. I've been accelerating on the highway, and pressed the resume button a bit prematurely, and it has indeed said 'not available'. I back off the accelerator and it takes. The difference may be using the resume button after ACC is initialized, rather than doing an initial startup of ACC with the center button.
Interesting.....I use ACC often (since my speeding ticket of $280!)..... whether during acceleration or backing off on pedal, it seems to engage irregardless. Hmmmm.....
 

·
Registered
Joined
·
2 Posts
I’ve had this issue before but it resolved itself overnight. It had nothing to do with dirty cameras; it was just the software having a temper tantrum. I haven’t yet gotten the June update. I’ve also never had a problem starting ACC regardless of whether I was accelerating or not. I do believe that the system puts the target speed differently depending on whether you are accelerating or decelerating, but I need to test that more since I just noticed that last week.
 

·
Registered
2021 Volvo XC40 Recharge
Joined
·
26 Posts
My first problem with this car, today while on highway I could not engage cruise control, it said "not available" even though I had the lane markers at the top of drivers screen. I pulled off highway and reset IHU and checked for any blockage (dirt, etc) in front of cameras on top of windshield and radar on front grill and found nothing, locked the car and walked away for 5 mins but no luck.

Anyone else have this problem or suggestion?
Same exact problem today. Clear sunny day all cameras clean. No ACC or driver Google map display. Rebooted, got map function back bot “not available” ACC. No software updates since delivery mid May in Massachusetts. Dealer is Not helpful, actually useless! Will call Volvo customer service again - not much use either though.
 

·
Registered
Joined
·
1,376 Posts
Did you try getting cruise control to engage with someone in front of you? Sometimes at first Margo needed to see someone to feel confident. Then she got used to it …

Semi joke above but I do remember the car occasional not wanting to engage adaptive unless it could see someone.

Despite all i joke about our cars settling down and adapting I really hope there is no machine learning in there …
 

·
Registered
Joined
·
15 Posts
My first problem with this car, today while on highway I could not engage cruise control, it said "not available" even though I had the lane markers at the top of drivers screen. I pulled off highway and reset IHU and checked for any blockage (dirt, etc) in front of cameras on top of windshield and radar on front grill and found nothing, locked the car and walked away for 5 mins but no luck.

Anyone else have this problem or suggestion?
check if the hood is completely closed, especially on the passenger side.
 

·
Super Moderator
Joined
·
254 Posts
This occasionally happens to me if I try to activate in traffic and the car ahead of me is decelerating. If it's unavailable continually in normal traffic moving at a fairly constant pace, it suggests a hiccup somewhere in the system.
 

·
Registered
Joined
·
12 Posts
Any updates on how to solve the ACC being unavailable?
Mine stopped working today when I "started" the car and second trip also no go. Will check tomorrow again if anything changes.
Window, sensors and camera all clean.
 
1 - 20 of 25 Posts
Top