Volvo XC40 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Maybe its been covered or I am missing something simple, but I picked up my 21 recharge last night I can't seem to get the GPS display in the gauge cluster. I have tried changing 'moods' with the menu button I have 2 blank centers and one with the car. Any help would be appreciated.
TIA
 

·
Registered
Joined
·
113 Posts
Hmm... I had to flip through a mode or two, but it did show up for my drive home from the dealer. Used the map the whole way home. Even in non-map mode (calm mode?) I was getting distance and turn notifications.
 

·
Registered
Joined
·
21 Posts
There's a bug of some sort mine disappeared after a week of use. One user reported soft reset fixes it. (Hold down play pause button 20 sec) Others reported use one key then the other and back again fixes it. Mine didn't fix until I updated the software today at the service dept.
 

·
Registered
2021 XC40 P8 - Bursting Blue - 01/21
Joined
·
42 Posts
It sounds like this issue has been had by many people. When I had this problem my turn signal sound, that fake relay noise, was gone. It went back to normal after the nav display issue was fixed. Has anyone else experienced this? I'm wondering if it was just a coincidence, or if this is also common with the nav display issue.
 

·
Premium Member
2021 White XC40 Recharge P8
Joined
·
269 Posts
My first glitch was the map not displaying in the instrument pane. Reset of AAOS (i.e., press home button on center display for 30 second) and it returned.
 
1 - 7 of 7 Posts
Top