Volvo XC40 Forum banner
21 - 30 of 30 Posts

·
Registered
Joined
·
22 Posts
Can you just use a micro sd card for this dash cam or are you required to get an app that uploads all the videos to cloud? Are you required to share all your contacts and other data to the manufacturer and related third parties?

Just wanted to say I got one of these last week and while it's still early in I'm super pleased with it. I only spent a few minutes to install it and it looks like a part of the car. I've been able to see individual files for every time we take the car in the file system, but probably don't plan to be checking on it very often. It requires you to have an app installed and connect to the device over wifi, or you can remove the sd card. I do think it could be a bit more secure but I don't see any issue with how it's attached. I'm also hoping since it's under the cars electronics it will hopefully not immediately melt in the texas sun.
 

·
Registered
Joined
·
15 Posts
From what I've seen the front camera is a fairly quick/easy install with good lighting and tools, but I have not seen anything on the rear install. Did it come with any instructions, or do you have any sources or advice on installing the rear camera?
We have a 22 model and the mirror cover is different from any video I could find. So it took a while to figure it out. No instructions for rear cam from Fitcamx. We had to figure this out from a youtube video for another camera. But rear cam was easier than expected. But we didn't lead the cable through the cable tube of the tailgate.
Camera works fine so far.
 

·
Registered
Joined
·
15 Posts
Can you just use a micro sd card for this dash cam or are you required to get an app that uploads all the videos to cloud? Are you required to share all your contacts and other data to the manufacturer and related third parties?
You can remove the sd card and copy the files. Als the app directly connects to the camera via a special Wifi connection, so no need to use the cloud.
 

·
Registered
Joined
·
35 Posts
I ran into a real-world situation with the Fitcam today and wanted to see if anyone had any advice. I was in a drive through and there was an accident that I was not involved in occur across the street. I did not see what happened, but heard the crash and saw the result.

I figured this would be a great test to see if I could see the actual accident with the Fitcam footage. I tried connecting to the wifi network via my iPhone for the cam and it said it cannot connect due to an unknown error, but it did see the network. I hit the power button on the camera to see if that fixes it, but still get the same error.

OK, that's concerning, but I guess I could grab the card when I get home and see the accident on my computer. So, I get home and connect the card to my computer to find the footage. I try to find it but there's a 20min gap between when I left my house and when I hit the power button. So, the camera captured me leaving the house, immediately after the accident, and the drive home.

I then look and see if an earlier trip for the day is captured (dropping the kids off at school) and I find that the first 10 min of the trip are captured, and then nothing until I started the next trip.

Are others experiencing random drops in the footage? I have a 64GB card so space is not an issue.

I'm now concerned that if there is a need for footage from an incident that I'm involved in that there will be a mysterious gap in footage when I go to find it.
 

·
Registered
Joined
·
15 Posts
Because of a stupid move another driver behind me made, my XC40 did a collision avoidance manoeuvre. Bit scary but quite spectacular. Feels like someone firmly pulls on your steering wheel.
I wanted to see what exactly happened when I got home and found out the camera wasn't recording. I thought it might have been because we had been waiting in the car for a long time before driving away so the camera didn't properly notice the start or something. I'll keep an eye on it from now on.
There is a small blue flashing light on the bottom of the camera that flashes when it is recording. According to the manual you don't have to start the camera. It will start recording when you start the car.
 

·
Registered
Joined
·
35 Posts
Tried again today and there’s zero footage of my morning drive. For my afternoon drive most of the trip was recorded but there’s a 5min gap right in the middle.

Is this typical? Has anyone talked to the company about reasons why or how to fix?
 

·
Registered
Joined
·
15 Posts
Is this typical? Has anyone talked to the company about reasons why or how to fix?
I have the same problems. Today I drove for 4 hours and I wanted to download some footage of the camera. I noticed it hadn't been recording all day. I tried to reset it, and finally It started recording again. But only for 2 minutes. A few hours after I got home I moved the car and those few minutes were recorded. When I removed the card it felt quite hot. When I moved my car is was cooler. Maybe the camera has problems with the heat. I'll do some more testing the next few days. Maybe I'll also try another SSD card. Maybe that helps. A smaller one might be less sensitive.

The manual (FITCAMX HD2 Dash Cam Universal Version User Manual - Manuals+) has a section about this: APP video file is empty, no video is loaded.
So it is a known problem.
 
21 - 30 of 30 Posts
Top