Volvo XC40 Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I love this car, but it almost killed me today. The ac, camera, and gps have been discussed before but today it shut off on the highway and coasted to a stop. It restarted right away. I called the Volvo dealership and they said this is the third exact story they have heard today.
Be careful out there.
 

·
Registered
Joined
·
9 Posts
Same thing happened to my wife with our baby on board
Call Volvo corporate
Someone is going to get killed by this
 

·
Registered
Joined
·
95 Posts
Yes, please let us know if this has happened after the cars were updated to the latest software, or if this is only happening in cars that haven't yet been updated. Thanks!
 

·
Registered
Joined
·
1,678 Posts
Oh no that is terrible.
Was this a demo car? Some demo cars got sold before they got software upgrade to fix this very feature.

If possible Could you link us your software build date.

That sounds horrible sorry you had to have that happen.
 

·
Registered
Joined
·
1,678 Posts
Really anxious to find out if the two cars that had this happen were post or pre the patch that is meant to fix this problem.
 

·
Registered
Joined
·
9 Posts
It was a demo that the dealer loaned us until our car was delivered
I couldn’t get a straight answer from the dealer as to the timing of the software update
 

·
Registered
Joined
·
95 Posts
It was a demo that the dealer loaned us until our car was delivered
I couldn’t get a straight answer from the dealer as to the timing of the software update
Ok, that's promising in the sense that it very well could have been a case of non-updated software. Still hoping to hear back from the original poster of this thread.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #11 ·
I brought it in for a software update 3 weeks ago. I assumed they updated the software but didn’t actually check the build number.
Also, I took it straight to the dealership after the incident so I don’t have access to the current software.
It was a demo, but theoretically had been updated.
 

·
Registered
Joined
·
95 Posts
I brought it in for a software update 3 weeks ago. I assumed they updated the software but didn’t actually check the build number.
Also, I took it straight to the dealership after the incident so I don’t have access to the current software.
It was a demo, but theoretically had been updated.
Hmmm so I guess we'll never know for sure. Interesting that both cases on this thread were demo cars, though.
 

·
Registered
Joined
·
1,678 Posts
Makes sense. Demo cars have had this problem on other threads.

Really this is a dealership/Volvo issue. As they should be hounding the people who have them to get them back.

Very sorry this happened to you.
 
1 - 13 of 13 Posts
Top