Volvo XC40 Forum banner
1 - 10 of 10 Posts

·
Registered
2022 XC40 Recharge
Joined
·
4 Posts
Discussion Starter · #1 ·
It’s almost August, and still no sign of the 2.2 OTA update. Currently running 2.1, automatic updates enabled, etc. yet nothing.
Local Volvo service centre say they’re yet to received it too, and have no ETA, etc.
Have we in Australia been dudded yet again??
 

·
Registered
2022 XC40 Recharge Twin Fusion Red
Joined
·
1,010 Posts
It’s almost August, and still no sign of the 2.2 OTA update. Currently running 2.1, automatic updates enabled, etc. yet nothing.
Local Volvo service centre say they’re yet to received it too, and have no ETA, etc.
Have we in Australia been dudded yet again??
We have it, but the dealer installed it a couple weeks ago when we went in for the sticky rear brakes service. I also mentioned connectivity issues, which is the line item they applied the software update against. There's quite a few bugs in this release...maybe they've paused it to work on them? Not sure...
 
  • Like
Reactions: jimmyhay

·
Registered
Joined
·
5 Posts
It’s almost August, and still no sign of the 2.2 OTA update. Currently running 2.1, automatic updates enabled, etc. yet nothing.
Local Volvo service centre say they’re yet to received it too, and have no ETA, etc.
Have we in Australia been dudded yet again??
We are having 2.2 downloaded manually by the dealer tomorrow. Apparently there are problems with the OTA download and I know of other that have had to have a manual download.
 

·
Registered
2022 XC40 Recharge
Joined
·
4 Posts
Discussion Starter · #4 ·
... I also mentioned connectivity issues, which is the line item they applied the software update against. ...
Interesting - do you mean the update was applied to fix connectivity issues or caused them? On ver 2.1, we are having lots of connectivity issues (patchy SOC in the Volvo on Call app, occassional loss of LTE/GPS, etc) and are constantly force-resetting the TCAM modem. Dealer service centre is telling us to wait for OTA 2.2 to resolve them - yet still we are waiting!
 

·
Registered
Joined
·
5 Posts
Interesting - do you mean the update was applied to fix connectivity issues or caused them? On ver 2.1, we are having lots of connectivity issues (patchy SOC in the Volvo on Call app, occassional loss of LTE/GPS, etc) and are constantly force-resetting the TCAM modem. Dealer service centre is telling us to wait for OTA 2.2 to resolve them - yet still we are waiting!
Talk to your dealer. They will probably book you in for a manual download like us.
 

·
Registered
2022 XC40 Recharge Twin Fusion Red
Joined
·
1,010 Posts
Interesting - do you mean the update was applied to fix connectivity issues or caused them? On ver 2.1, we are having lots of connectivity issues (patchy SOC in the Volvo on Call app, occassional loss of LTE/GPS, etc) and are constantly force-resetting the TCAM modem. Dealer service centre is telling us to wait for OTA 2.2 to resolve them - yet still we are waiting!
Prior to V2.1, our connectivity was pretty patchy, and that's when I advised dealer about connectivity issues when I made the booking for the brakes. Then we got 2.1 via OTA and connectivity was somewhat better. I still had connectivity listed as an issue, but I told them just to check for codes etc. as it seemed to be better after V2.1 installed. At the service, they installed V2.2. Connectivity is still a bit funny sometimes, but always seems to come back within a couple minutes of driving off. The main issue with 2.2 is Google Assistant, which seems to be problematic. I think maybe there was a Google Assistant update recently so maybe that will be more stable now. Haven't driven the car a whole lot since the dealer visit/2.2 install.
 
  • Like
Reactions: jimmyhay

·
Registered
2022 XC40 Recharge
Joined
·
4 Posts
Discussion Starter · #7 ·
OK - thanks mate, I'll try to book our dealer to upgrade it. They're a friendly lot, but still seem a bit clueless about this new-fangled EV they sell...
 

·
Registered
2022 XC40 Recharge
Joined
·
4 Posts
Discussion Starter · #9 ·
The dealer service centre ended up installing OS 2.2 from scratch manually (i.e. not upgrade). They couldn't explain why OTA hadn't worked.
So far, all seems ok... hopefully some relief from the TCAM issues and future OTAs actually work!
 
1 - 10 of 10 Posts
Top