Volvo XC40 Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
This weekend I did a trip to Canada, but just found out the "Cruise Control" / "Adaptive Cruise Control" did not work. It always shows "unavailable" no matter what. I tried reset by pressing the center "magic" button. I also tried "factory reset" in the settings. Neither seems solving the issue.

The very day I purchased the car, I indeed used the Adaptive Cruise Control on my way back home. And it worked just fine. No idea what happened. Anyone has this similar experience?

Another issue found during this trip. The speedometer won't change to metric (still showing your speed as MPH) when changing the setting from "US" to "Metric". However the speed limit info started to show 100km/h, and it's changed to metric info in google map in the center infotainment screen.
 

·
Registered
2021 XC40 Recharge
Joined
·
125 Posts
Could it be that your profile is limited like if you are using the orange valet key?
 

·
Registered
Joined
·
279 Posts
I actually had all 3 keys with me in the car, but the profile was linked to one of the black keys.
If there is dirt or a smashed dead bug in front of the camera lens the system cannot see the lines on the road or vehicles in front and will not engage - perhaps clean the area in front of the camera which I believe is in the windshied glass behind the interior rearview mirror.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
If there is dirt or a smashed dead bug in front of the camera lens the system cannot see the lines on the road or vehicles in front and will not engage - perhaps clean the area in front of the camera which I believe is in the windshied glass behind the interior rearview mirror.
I hope this is not the reason. If it was indeed due to any bug or something blocking the lens, I would never consider Volvo again in my life. You will absolutely have bugs all over your car's front, hood, windshield, etc. when driving in summer on highways.

And even if ACC may not be working due to this reason, anyone would still expect the regular CC working. But there's no way you can turn it on.

BTW, the lane keep function was working just fine. So that means the car can really detect the lines well.
 

·
Registered
2021 XC40 P8 - Bursting Blue
Joined
·
245 Posts
I hope this is not the reason. If it was indeed due to any bug or something blocking the lens, I would never consider Volvo again in my life.
Virtually every car using cameras or radar could be affected by bugs or dirt, so it's not just Volvo. You'd have to get something pretty old to avoid cameras.

I had a 2010 Tacoma that would get a dirty rear-view camera pretty much anytime there was weather. Not the same as a camera used for safety or driving aids, but still...
 

·
Registered
Joined
·
157 Posts
I would never consider Volvo again in my life. You will absolutely have bugs all over your car's front, hood, windshield, etc. when driving in summer on highways.
A dirty camera will affect all cars with lane assist. It can also happen in a hard rain or fog. I have had the same warning on a BMW and Chevrolet

Professing and declaring your desire to avoid a company because of a dirty camera that cannot visualize the road and provide lane assistance is your decision.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #8 ·
A dirty camera will affect all cars with lane assist. It can also happen in a hard rain or fog. I have had the same warning on a BMW and Chevrolet

Professing and declaring your desire to avoid a company because of a dirty camera that cannot visualize the road and provide lane assistance is your decision.
As I mentioned, the lane keep functioned well. So it's not because of the lens, I would assume.

And I drove 400+ miles on highway on that single day, and got ACC unavailable no matter what. I swiped the front camera with my finger (even I did not see any bug whatsoever), and I got several rains along the route. I have no ground to blame bugs.

The bottom line is, if ACC is not working, CC should be working anyway, right?
 

·
Registered
Joined
·
279 Posts
As I mentioned, the lane keep functioned well. So it's not because of the lens, I would assume.

And I drove 400+ miles on highway on that single day, and got ACC unavailable no matter what. I swiped the front camera with my finger (even I did not see any bug whatsoever), and I got several rains along the route. I have no ground to blame bugs.

The bottom line is, if ACC is not working, CC should be working anyway, right?
That is how it works on my Ford F150 - not sure how volvo has set it up on the Recharge XC40.
 

·
Registered
Joined
·
12 Posts
Did you ever resolve the ACC not working and if yes how?
My ACC suddenly became "unavailable" today and I cannot get it to work, lane assistance works no problem. The window and cameras are clean.

Any suggestions?
 

·
Registered
2021 XC40 Recharge
Joined
·
111 Posts
Did you ever resolve the ACC not working and if yes how?
My ACC suddenly became "unavailable" today and I cannot get it to work, lane assistance works no problem. The window and cameras are clean.

Any suggestions?
It will probably work ok tomorrow, thats what happened to me.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #12 ·
Did you ever resolve the ACC not working and if yes how?
My ACC suddenly became "unavailable" today and I cannot get it to work, lane assistance works no problem. The window and cameras are clean.

Any suggestions?
I found the left side of the hood (facing the car from the front) was not fully closed. I just guess that could be the reason, because I have been having no such issue at all since then.
 

·
Registered
Joined
·
12 Posts
I found the left side of the hood (facing the car from the front) was not fully closed. I just guess that could be the reason because I have been having no such issue at all since then.
i would expect a warning light to show that the fronk is not close, but will check thanks.
 

·
Registered
Joined
·
147 Posts
Returned from dealer today. Dealer informed wife that it was a software issue. She did but engage cruise control on the way home but did not see the error messages.

Off topic: Dealer required her to return the courtesy car filled with gas but gave her car back at 40%. 😡
 
1 - 16 of 16 Posts
Top