Volvo XC40 Forum banner
321 - 340 of 423 Posts

·
Registered
Joined
·
1,003 Posts
I would be really annoyed by voc apart from the fact we all signed a “voc is broken and will be broken for x time” agreement. At no point have they said it actually works.

If they say it works and is final release and we have the same poop show then I will be cranky.
 

·
Registered
Joined
·
46 Posts
I would be really annoyed by voc apart from the fact we all signed a “voc is broken and will be broken for x time” agreement. At no point have they said it actually works.

If they say it works and is final release and we have the same poop show then I will be cranky.
I'd really just like to know why a select few of us haven't been deemed worthy yet. Some sort of lottery going on?
 

·
Registered
Joined
·
1,003 Posts
For the advanced beta? If so no idea. I never got invited either. Maybe everyone who got invited had written to Volvo. Or maybe like you said it is random. Random is actually a valid method for picking people to give the option to join a beta. Not the best but it is a valid one.
 

·
Registered
Joined
·
541 Posts
For the advanced beta? If so no idea. I never got invited either. Maybe everyone who got invited had written to Volvo. Or maybe like you said it is random. Random is actually a valid method for picking people to give the option to join a beta. Not the best but it is a valid one.
1) My dealer wasn’t aware of any documents out there so I didn’t even sign anything when taking delivery - not shocking since i had to make them a copy of the $1k accessory and Charpoint credit which they had no clue of
2) I didn’t get any email or invites as beat tester on VOC.

it was literally trial and error as owners here Continued to post On trying different venues and steps. Collectively, it had somehow worked on my end with the final step of updating the app version on phone.

just today, when I looked t app again, the color of color has now reflected the right color

hope they roll out something more stable for everyone to use it
 

·
Registered
Joined
·
29 Posts
That is a great resource tells you everything you need to know on pairing the app and troubleshooting - Thanks for posting that!! Worked perfectly in less than a half hour!!
Glad it helps someone. The fact that it still doesn’t work for me makes me think that there is something in the IHU that is still not getting reset properly when factory reset is applied.
 

·
Registered
Joined
·
1,003 Posts
Or the product is still buggy and does not work on every car hence why it is not released.
 

·
Registered
Joined
·
679 Posts
What I did determine on my dealer visit yesterday is they said all my software is up to date. Of course I would hope any other TSBs were were confirmed. Now to just get the missing key removed and maybe I can pair VOC.
 

·
Registered
Joined
·
118 Posts
May be it'll help someone but unfortunately it did not help me with pairing my iPhone to VOC (tried following the whole process according the guide after factory reset and using key 1 in admin profile did not help either.)
Received this pdf from my dealer as well. With the latest app installed on my cell everything worked like a charm after following the steps in the document. I would suggest to try and update your existing app to the latest, but DO NOT DELETE the installed app (bad things happen if deleting, apparently)- just update the existing app and as a final step reboot the modem (hold down the defrost button for 20 secs) and after that everything that's supposed to, just works in the app..
 

·
Registered
Joined
·
5 Posts
Followed the steps in the document and got the same place I was before... paired but "error retrieving devices" and no charging status. Also, note that is was impossible to unpair the phone per the instructions because there was no "disconnect" button on the specified page (just the error message). So had to delete the app and then factory reset the car. I was actually feeling positive that it would work, because I noticed in the car that the data sharing was not enabled, and so per those instructions, my previous setup should not have worked. But fixed that during the factory reset and still got the same answer :(
 

·
Registered
Joined
·
1 Posts
First post, and have not read the whole thread, so sorry if this is a repost. I had the old app with an XC60 T8 and just got the XC40 P8… could control the locks, but not the preconditioning or see the charge level. The following permission needed to be enabled on each of my profiles. I found it and told Volvo service - it was not in their help protocol, so try it at your own risk…

In the car… settings -> applications -> permissions -> show all -> com.volvocars.vehicle functions

on the app… sign out and in.

worked within 15 minutes. Good luck. Hope this helps others.
 

·
Registered
Joined
·
274 Posts
In the car… settings -> applications -> permissions -> show all -> com.volvocars.vehicle functions

on the app… sign out and in.

worked within 15 minutes. Good luck. Hope this helps others.
Interesting. Unfortunately, it didn't change anything for me - my app is exactly as intermittent as before. Sometimes it will successfully show SOC & Climate, but not often. It almost always shows lock/unlock, though.

The fact that it sometimes works properly - without enabling this permission - leads me to believe this is not the relevant issue, at least in my case. I still have to guess this is an intermittent "car to cloud" communications problem or back-end server issue.

Not sure if there's any way for you to know for sure whether this permissions actually "fixed" things for you - or whether it just happened to intermittently work at random at the same time you did this.
 

·
Registered
Joined
·
64 Posts
I’ve tried everything and I still get just the Could not load devices error with — for charge. It did say wake up to 36 hours so I wonder if there’s some manual process that has to happen to make this work.
 

·
Registered
2021 XC40 Recharge
Joined
·
43 Posts
got the XC40 P8… could control the locks, but not the preconditioning or see the charge level.
Interesting, I had the same symptom for days until yesterday where I decided to perform both a console and LTE reboot for the 1st time. Just before that, the app showed an extra tab for 'Timers' under the climate section. Now, it doesn't have the 'Timers' option but, at least all of the features shown now work in the app. When I say "work", I mean most of the time. Maybe 10% of the time I'll get an error message upon performing an action like unlocking the doors.
 

·
Registered
Joined
·
46 Posts
I've had the app forever and usually had the ability to lock and unlock car. I never paid attention to it as I knew it was still a work in process. Last week I read this chat and deleted the old app and downloaded the new app and linked to car and also for the first time signed into the Volvo on call account on my car directly (with my Volvo id). Still didn't work except unlock/lock. I delinked my Volvo on call account on my car last week and never logged back in. I went in this morning with all three keys to log back into the Volvo on call account on the car and as I opened the app it was fully working, before I logged into the account on the car. I reconnected my account on the car and everything still worked.
 

·
Registered
Joined
·
541 Posts
Need a HUGE favor ! Can someone please post the latest version of software you currently have ???

Tech told me there was an “update” they did today after I told theme there was a Recall 10078 regarding update BUT it could have been dated since when I got my car 3 weeks ago I was assured all updates were done - mine was March version (but I didn’t take a picture)
My VOC had finally worked since last week and since they claimed that they “updated” something today (which I seriously don’t trust what they’re saying..” now my VOC is GONE ! SOC status gone …. So don’t know what the heck they did ! When asked “oh what software update? I wasn’t aware since the Mar version”. Tech response was “oh yeah we update it today, they always sneak in

when I get my car back tomorrow (they’ve been saying that everyday - it’s in there for brake issues ) I want to compare the pic.

Geezz….what he said was like insulting my level of already low intelligence when it comes to software!
 

·
Registered
Joined
·
274 Posts
Need a HUGE favor ! Can someone please post the latest version of software you currently have ???
Here's what I have. This is what Volvo calls "Updates from and including April 2021". The AAOS kernel was built on March 18, but it's not clear on what date the Infotainment software was built (presumably the QA1A... thingy?).

868
 

·
Registered
Joined
·
541 Posts
Here's what I have. This is what Volvo calls "Updates from and including April 2021". The AAOS kernel was built on March 18, but it's not clear on what date the Infotainment software was built (presumably the QA1A... thingy).

View attachment 868
THANK YOU THANK YOU !
I will ask the Tech tomorrow (assuming car is ready tomorrow) how to interpret the complete string of info. That way If there are supposedly “new version” would be nice to validate so.
Somehow I don’t buy what the Tech guy said - I had the March software version too. I want to see prove of WHAT update ??!!! I’d been totally kicking trash can if whatever they DIs cancelled the VOC ….
Thanks again !
 
321 - 340 of 423 Posts
Top