Volvo XC40 Forum banner
1 - 7 of 7 Posts

·
Registered
2022 XC40 Recharge Twin Fusion Red
Joined
·
1,268 Posts
Discussion Starter · #1 ·
My parents have a 2019 XC40 T5 R-design and recently they've noticed there's no heat blowing out the passenger side (floor, vents or defrost). Anyone else had this problem? I guess they'll have to visit the dealer. They did just have the cabin filter replaced, but not sure whether that could have caused an issue or whether it's unrelated, as they hadn't been using the heat before the filer was changed.
 

·
Registered
Joined
·
6 Posts
For essentially the last 6 mo I have seen that now and again the driver and traveler side victory fundamentally unique temperature air... one side cool/winter open air temp and other exceptionally hot air. This happens when the double controls are set to a similar temp, generally I have it between 68-74. I can't track down a strong example to these events. To some extent a fraction of the time it appears to work appropriately, and I ordinarily don't see the distinction right off the bat in my drive. At any rate, it doesn't make any difference what temp I set either side to, it blows inverse temps! Any one else have/fix this issue? Somebody recommended perhaps the warm/cool air blender was stuck, yet how does that make sense of the temp changing haphazardly in the center of a drive?



snaptube vidmate
 

·
Registered
Joined
·
3 Posts
I have a 2019 XC40 T4 and recently found that only cold air is blowing out the driver and passenger vents with the heat on. I read up on it on line and ruled out the heater core clogging (both input and output hoses were hot) and checked the coolant level which was fine and also ruled out the thermostat since the heater core was hot. The car only has 17K miles and is garaged most of the time so the cabin air filter is not it either.

That leaves the blend door not switching between A/C and heat. The car is currently at the dealership and they have also narrowed it down to the blend door as well. Will report back after the repair is completed.
 

·
Registered
Joined
·
3 Posts
Well they replaced two motors that according to them control the blend door and defroster. Apparently something shorted and took both motors out.

Last year both heated seats stopped working and had to be replaced. Starting to wonder if this car has some kind of electrical issue and this will continue. Out of the warranty period now so I am concerned.
 
1 - 7 of 7 Posts
Top