Evap System - Check Engine Sensor / Break Issue - Volvo XC40 Forum
 1Likes
Reply
 
LinkBack Thread Tools
post #1 of 19 (permalink) Old 06-29-2018, 11:26 AM Thread Starter
Junior Member
 
Join Date: Jun 2018
Posts: 4
Arrow Evap System - Check Engine Sensor / Break Issue

Hello All:

I have had my XC40 since April 2018. I ordered it in January and very excited for the car. I've had two issues thus far and I'm curious if anyone else has.

1. Check engine Light (Orange) for Evap System

- This was from a sensor and they stated it was for the emissions system. The lady informed me there was a similar issue with the XC90's when they first came out and that they eventually added something in the gas tank to make sure when filling the tank emissions couldn't get in.

Has anyone else had this issue?

2. Brakes are squeaking already

- I use my car for commuting, and don't really speed that much. I'm pretty easy on the brakes. I have used the semi-pilot system regularly and noticed that it sometimes overcorrects with the braking. She stated they tested the brakes and didn't "notice anything". The answer got sketchy when she said that "Volvo hasn't released a bulletin about brakes, and because they haven't they couldn't do anything" This led me to believe there may be something more to the braking issue, but it hasn't been reported yet.

Has anyone else had this issue with brakes squeaking? Any thoughts on what the issue may be?

I'm very happy with my purchase, and know its a new model. I do feel its important to see if other people have similar problems, so we as early adopters don't get stuck paying for brakes or emissions issues, because we are the first to purchase it.

I'm also have the report that the technician ran. In case any volvo technicians are out there and want to look at the results. The forum won't let me upload it because the file size is too big. Feel free to message me and I can send it directly.

Thanks in advance for any commentary
Lsu189 is offline  
post #2 of 19 (permalink) Old 07-10-2018, 08:18 AM Thread Starter
Junior Member
 
Join Date: Jun 2018
Posts: 4
Update

My Check Engine Light has come on again. I had not pumped any gas in two weeks, so that couldn't be it.

Has anyone had this issue? It seems odd to me that it has happened twice. I bought the vehicle on April 22...

This is ridiculous. Bringing it in again for service on Thursday.
Lsu189 is offline  
post #3 of 19 (permalink) Old 07-11-2018, 12:25 AM
Member
 
Join Date: Apr 2018
Location: Pasadena CA
Posts: 60
Garage
What is the OBD code? I once had a OBD code for an evap leak on a Jeep. The dealer determined that I did not have an actual leak but the sensor was in error and it would cost as much to fix the sensor as if I had a leak

T.S. Eliot:
Old men ought to be explorers
yakers is offline  
post #4 of 19 (permalink) Old 07-13-2018, 01:17 PM Thread Starter
Junior Member
 
Join Date: Jun 2018
Posts: 4
@yakers . Thank you for the response. It was a check engine light, I believe the OBD code is: ECM-P044100 (but I'm not positive if thats the code you're looking for)

Update: Just picked my XC40 up, the dealer stated that Volvo determined it was a canister purge valve that will need to be replaced. Here is an article I googled about the piece: https://www.fiix.io/car-advice/artic...er-purge-valve

Because it's a Volvo speciality part, it has to be ordered and next week they'll take 1-2 days to replace the part. Seems like a long time for what they say the problem is, but I'd rather them take their time...

The dealer also stated that another XC40 was coming in next week for a check engine light issue, so it may be something that is more commonplace down the road.
Lsu189 is offline  
post #5 of 19 (permalink) Old 07-14-2018, 07:11 PM
Junior Member
 
Join Date: Jul 2018
Posts: 13
Hi I have check engine code on 6/11/18 evap purge valve issue, soft ware was updated no help, code came on again next day. Its for a evap purge valve, part has been on order since 6/27/18. Coming from Sweden on back order...

Purchaced car 3/24/18. @ 800 miles 3 weeks windshield cracked ( sitting in garage) volvo did agree to replace but took till 6/20 to get in (it was smashed, next one came in brackets were bent, third one installed on 6/26.

Also 4/23 had drivers door was rubbing against the fender, don't know if there was some sort of body flex issue that caused the door to rub and wind shield to crack.
So far dealer has been doing what it can parts have been the issue. I have got a loaner car for almost 3 weeks, a audi q5 so at least we have a similar loaner.

Sorry for the long post
Dcrism83 is offline  
post #6 of 19 (permalink) Old 07-16-2018, 10:19 AM
Junior Member
 
Join Date: May 2018
Posts: 24
Quote:
Originally Posted by Dcrism83 View Post
I have got a loaner car for almost 3 weeks, a audi q5 so at least we have a similar loaner.

I'm baffled when I hear that a car company puts customers in a competitor's car as a service loaner. That's a seriously stupid idea. Does your dealership sell both Volvo and Audi?
White Shadow is offline  
post #7 of 19 (permalink) Old 07-16-2018, 02:10 PM
Junior Member
 
Join Date: Jul 2018
Posts: 13
Yes they have volvo audio and Lincoln, I could of had a volvo 40 something but it's smaller the q 5 was available that was comparable comfort wise ( prefer the xc40) electronics are better.
Dcrism83 is offline  
post #8 of 19 (permalink) Old 07-18-2018, 11:06 AM
Junior Member
 
Join Date: Jul 2018
Posts: 13
Do you have any update?
I was told the evap purge valve is still back ordered and no eta available...so mine still in shop
Dcrism83 is offline  
post #9 of 19 (permalink) Old 07-26-2018, 08:17 AM Thread Starter
Junior Member
 
Join Date: Jun 2018
Posts: 4
Update

@Dcrism83 I'm sorry to hear about your experience thus far with the XC40 and appreciate the feedback with your similar issue with the canister purge valve.

After my last post on 7/13, Volvo informed me , as well that the canister purge valve was on backorder. They stated it should be here within 10 business days, so I'm expecting to hear from them any day now. (hopefully not backordered further) When I go in, I will make sure and request any additional information on the problem to share on the forum.

Were you able to get your purge valve installed yet @Dcrism83 ?
Lsu189 is offline  
post #10 of 19 (permalink) Old 07-26-2018, 02:43 PM
Junior Member
 
Join Date: Jul 2018
Posts: 13
No I have no update, the car has been out of service for 30 days for just this issue. Total of 38 days, for everything. I've sent volvo registered letter perusing lemon law, love the car but I've waited 30 days for this part. The wind shield was cracked that took 2 months to get in I could drive with a crack, but if it was smashed it would not be drivable. The part supply network is behind in today's world parts can be shipped in days not weeks and months.
I'm afraid this get repaired what could be next.
Dcrism83 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Start/Stop System White Shadow Volvo XC40 General Discussion Forum 17 07-13-2018 08:00 AM
2019 Volvo XC40 Overview XC40Admin 2018+ Volvo XC40 News 0 02-20-2018 06:49 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome